CSPro Manual
Data Verification and Systems Assessment Modules
For the Data Verification and Systems Assessment (DV/SA) survey, automated tools for electronic data collection and data processing have been developed using the Census and Survey Processing System (CSPro) software. A detailed manual with step by step instructions for using CSPro is available as a stand-alone document. The following topics are covered in the CSPro manual:

1.1 Introduction .......................................................................................................................... 5
   CSPro capabilities .................................................................................................................. 5
   CSPro for the DV/SA survey ................................................................................................. 7

1.2 Technical information .......................................................................................................... 8
   Hardware and software requirements ..................................................................................... 8
   Software installation ................................................................................................................ 8

1.3 Facility DV/SA CSPro application ....................................................................................... 11
   Preparing to open the Facility DV/SA CSPro application ..................................................... 11
   The Facility DV/SA CSPro files structure ............................................................................ 11

1.4 Configuring the Facility DV/SA application ....................................................................... 14
   Create the sample file .............................................................................................................. 14
   Create the replacement facility sample file .......................................................................... 16
   Create the interviewer ID file ............................................................................................... 17
   Configure the DV module selection ....................................................................................... 18
   Adding new DV modules ........................................................................................................ 18
   Specify DV reporting months ............................................................................................... 18
   Change the display language ................................................................................................. 18

1.5 Getting to know CSPro ......................................................................................................... 20
   Start CSPro and open the Facility DV/SA application ........................................................... 20
   Explore the data entry application ........................................................................................ 21

1.6 Modifying the Facility DV/SA application ......................................................................... 24
   Modify a dictionary item ......................................................................................................... 24
   Delete a dictionary item .......................................................................................................... 33
   Modify logic ............................................................................................................................. 34
   Add a new record and form to the Facility DV/SA application ............................................. 39

1.7 Run the data entry application ............................................................................................. 42
   Check the settings .................................................................................................................. 42
   Review forms ........................................................................................................................ 44
   Run the application on a computer with Windows operating system .................................. 44
   Preparing the application to run on a tablet with an Android operating system .................. 45

1.8 Set up data synchronization ................................................................................................. 47
   Set up Gmail and Dropbox accounts for the survey .............................................................. 47
   Synchronization with Android tablet ................................................................................... 48
   Entering data on an Android tablet ....................................................................................... 51

1.9 Concatenate data .................................................................................................................. 53
   Concatenate data files from Android tablet ........................................................................... 53
   Concatenate data files from Windows computer ..................................................................... 54

1.10 Review data for completion in the field .............................................................................. 56
1.11 Review and edit data in CSPro ................................................................. 59
  Open the concatenated data set using the data entry application ........................ 59
  Review cases for key fields ........................................................................ 59
  Check for any duplicate facility codes ......................................................... 60
  Delete a case ............................................................................................ 62
  Split final data set from supervisor validation data set .................................. 63
  Compare supervisor validation to original data collection ............................. 63
  Batch application for completeness ........................................................... 67
  Dependent verification (if applicable) .......................................................... 69

1.12 Batch edit application for indicator generation ....................................... 70
  Open and explore the batch application ...................................................... 70
  Assign strata for analysis .......................................................................... 70
  Apply weights ......................................................................................... 72
  Edit country specific items ...................................................................... 73
  Run the batch application ....................................................................... 73

1.13 Export indicators .................................................................................. 74
  Open the CSPro Export Data application .................................................... 74
  Select items for export ............................................................................ 74
  Export data for the Facility DV chartbook .................................................. 74
  Export data to other file formats for additional analysis .............................. 75
  Open the CSPro Export Data application .................................................... 75
  Select items for export ............................................................................ 75
  Export data .............................................................................................. 76

1.14 District DV/SA application ................................................................... 77
  Preparing to open the District DV/SA CSPro application ............................. 77
  The District DV/SA CSPro files structure .................................................. 77
  Configure the District DV application ....................................................... 79
  Create the sample file ............................................................................. 79
  Create the interviewer ID file ................................................................... 80
  Configure the DV module selection ......................................................... 81
  Adding new DV modules ......................................................................... 81
  Change the display language ................................................................... 81
  District settings for entering facility level data into an electronic health information system ................................................................. 82
  Edit and run the District DV/SA application ............................................ 83
  Select items for export ............................................................................ 83
1.1 Introduction

Electronic data collection facilitates collection of more accurate and reliable data in a more efficient, timely manner. Handheld data collection devices offer solutions for data collection errors and disorganization. These electronic tools come in various forms, the most commonly used devices being handheld computers (known as tablets) or smartphones. Smartphones differ from handheld computers in that they combine the functions of a computer and a telephone, whereas a tablet cannot function as a telephone. Global Positioning System (GPS) devices are handheld electronic devices often used in conjunction with handheld computers to determine precise location using geographic coordinates.

Electronic data collection devices have become gradually more popular for field surveys due to decreasing costs and increasing computation and functional capacity. Not only does electronic data collection offer a more efficient and accurate route of data collection and dissemination, workers are often eager to put modern technology to use for practical purposes. The time it takes to train staff in the use of many of electronic data collection devices can be as short as one day.

The advantages of electronic data collection are vastly evident. There are a number of data validation procedures that can be programmed into an electronic data collection device in order to facilitate the collection of more accurate and reliable data: skip patterns, range controls, standardized responses, and mandatory question responses. The automatic progression of the questionnaire and the standardized responses make it easy for interviewers to administer the survey. Time is not wasted scrutinizing the progression of the questionnaire or writing lengthy responses.

As the size and scope of a survey increases, so do the benefits of electronic data collection. Large volumes of data are subject to the risk of more data collection errors, and the time saved in data collection, data entry, data cleaning, and data dissemination is substantial. With electronic data collection, information can be in the hands of decision-makers in the same day that the data is collected.

For the Facility DV/SA survey, electronic data collection is carried out through the use of the Census and Survey Processing System (CSPro) software.

CSPro is a software package for entry, editing, tabulation, and dissemination of census and survey data. CSPro lets you create, modify, and run data entry, batch editing, and tabulation applications from a single, integrated development environment. The data are stored in text files described by data dictionaries. CSPro was developed jointly by the U.S. Census Bureau, Macro International, and Serpro, SA, with major funding from the U.S. Agency for International Development.

CSPro is not intended to provide database management capabilities; however, the data generated and/or manipulated by a CSPro application may be imported into a database system. While CSPro provides some tabulation capabilities, it is not intended to replace more sophisticated statistical analysis software such as SAS, SPSS, Stata, etc. In addition, even though CSPro includes a module for generating thematic maps, it cannot be considered a geographical information system [GIS], as the maps cannot show the multiple layers available in a true geographical information system.

CSPro is in the public domain. It is available at no cost and may be freely distributed. It is available for download at http://www.census.gov/population/international/software/cspro/csprodownload.html.

CSPro capabilities

Enter, modify, and verify data

CSPro users can create data entry forms (screens) for data capture. The application designer has full control over form layout. CSPro supports rosters, consistency checks and skip patterns of unlimited complexity, user-defined messages and menus, multiple lookup files, and produces operator statistics. CSPro data entry applications run on
Windows and Android devices (The Android app for the interviewing module can be downloaded from Google Play. For Windows, the same installation package is used for the development process as well as for the interviewing). The version used for Android is also capable of synchronizing with Dropbox, or to upload files using ftp.

Once a case has been completely entered, the operator can modify any part of the existing data and can add or remove information (subject to application constraints).

CSPro supports both dependent and independent verification (double keying) to ensure the accuracy of the data entry operation. Using independent verification, operators can key data into separate data files and use CSPro utilities to compare them. Using dependent verification, operators can key data a second time and have CSPro immediately compare it to what was keyed the first time on a field by field basis.

**Process census or survey data**

Given an existing data file, a user can develop a CSPro application that will examine the file for inconsistencies, structural defects, or other errors. CSPro permits the user to generate detailed reports on all errors found; the user may also create sub-files from the original data, and may use multiple look-up files during the validation and/or report-generation process.

**Manipulate data files**

CSPro permits the user to re-structure existing data files and to create subsets of data in separate files. New files may also be created by merging two or more case-related files. Data files in software-specific formats may be created for import into spreadsheets and some statistical packages.

**Tabulate data**

The user can create an application to produce frequency distributions or cross-tabulations using two to four variables. Results can be displayed either globally (for the totality of the data file) or according to one or more elements of the geographic hierarchy. Tabulations may show only percentages, or percentages in conjunction with counts; data may be weighted or un-weighted.

**Create thematic maps**

If computerized maps are available for the relevant geographic areas, CSPro may be used to generate cross-tabulations whose results can be joined to the map files to produce thematic maps for display of information. Thematic map display parameters permit a high degree of customization in the presentation of these data.

**Use and share external files**

When a data file is to be used by more than one person, a CSPro dictionary can be created and distributed among users of the data to facilitate access. The different needs of individual users can be catered to by including multiple value sets for variables, so that each user’s requirements are met.

**Examine data files**

CSPro provides language elements that will permit the specification of logic to carry out a detailed examination of a data file. Elements of the file may be tested against other elements of the same file or against elements of one or more other files, and the user may generate reports showing the results of the examination. CSPro also provides a tool for comparing the contents of two data files. This tool will generate a detailed report to the user documenting any differences found.

**Interactive editing**

CSPro language elements can be used to construct a series of tests to be carried out on a case-by-case basis using the CSEntry module. Whether adding a new case or modifying an existing case, CSPro instructions permit
interactive editing and correction of data elements. If the user desires, a report on editing activity may be generated and saved for printing after the session is completed.

Examine results of editing

Whether the user is carrying out interactive or batch editing, the CSPro language permits the preparation of reports with detailed information on cases tested, errors found, and errors corrected. These reports are written to disk in ASCII-text format and may be viewed with any text viewer, such as CSPro’s utility Text Viewer, and may also be printed. They provide documentation of work carried out and permit analysis of types and frequency of errors.

CSPro for the DV/SA survey

As CSPro has been chosen for the implementation of the DV/SA survey, a standard CSPro application has been developed. This document provides instructions on how to adapt the standard Facility DV/SA and District DV/SA CSPro applications at country level, as well as how to implement the CSPro applications for data entry and data processing.
1.2 Technical information

Hardware and software requirements

The following requirements are necessary in order to use CSPro for data collection:

Computer hardware and software specifications

CSPro 7.1 runs under Windows Vista, 7, 8, and 10. It does not run under Windows 8 RT. The Android data entry module requires Android version 4.0 or higher.

RECOMMENDED CONFIGURATION FOR QUESTIONNAIRE DEVELOPMENT

- Desktop or laptop computer
- Pentium Processor
- 512 MB of Ram
- SVGA monitor
- Mouse or touchscreen
- 100MB of free hard drive space
- Microsoft Windows Vista, 7, 8 or 10. (NB: CSPro does not run on Windows 8 RT)

CONFIGURATION FOR INTERVIEWER’S APPLICATION

- Windows 8 touch screen tablet (or Windows 7/8/10 laptop computer with mouse)
  
  or

- Android tablet with operating system 4.0 or higher

Software installation

Install CSPro on a computer/laptop

The following is based on a Windows 7 setup. Your steps may vary if using a different operating system.

1. Download the CSPro application from http://www.census.gov/population/international/software/cspro/csprodownload.html

2. Install CSPro 7.1 to your computer by double-clicking on cspro70.exe (the last digit of the version number might change as new releases are published). This will start the installation wizard.

3. CSPro allows you to select which components of the system you want to install. During the installation you will see the following component screen:
You have the following choices:

- **CSPro Suite**
- **Examples**
- For SARA, please install **ALL COMPONENTS** of the CSPro Suite even on tablets to use in the field as there are tools in the full application that are required for the program to run properly.
- The rest of the default settings for the installation are OK, so just click “next” until finished.

**Updating to CSPro 7.1 from CSPro 6.0**

If you have CSPro 6.0 installed on your computer, you can install CSPro 7.1 without affecting the CSPro 6.0 installation, and both versions can be run in parallel. Please notice, however, that version 7.0 is now the default program to open existing applications, and these are automatically converted to 7.0 format. You also have the option to remove CSPro 6.0 from your computer if you are no longer using it as this will simplify opening CSPro applications.

**Install CSEntry for Android devices**

The app is called “CSEntry CSPro Data Entry”, and can be found and installed from Google Play store (search for “CSPro”)

**Install CSPro on a Tablet PC (Windows 8)**

- The reactions to the user interface of Windows 8 have mostly been negative, and in combination with CSPro, it is a rather messy experience: Each CSPro component becomes one tile in the home screen, resulting in 15-20 new “tiles” on the start screen. If other programs also are installed, the user soon loses track amongst all the tiles. Hence, we recommend installing a tool called Classic Shell to get back the start menu and the general feel of Windows 7. Once the Classic Shell is installed, the installation of CSPro 7.1 is the same as for installing on a Windows 7 computer as explained above.
- The Classic Shell can be downloaded from [http://www.classicshell.net/downloads/](http://www.classicshell.net/downloads/). Double click on the installation file and follow the instructions to install.
The installation of CSPro on the tablet PCs after the Classic Shell is installed, is the same as installing on a Windows 7 computer – as explained above.

Uninstall CSPro

The following is based on a Windows 7 setup. Your steps may vary if using a different operating system.

1. From the Start button on the taskbar, select Settings → Control Panel.
2. Select Add/Remove Programs.
3. From the list of currently installed programs, click on CSPro 7.1
4. Click the Change/Remove button.
5. Click “Uninstall” at the top of the window.
6. At the prompt, click OK to confirm that you want remove CSPro 7.1. The uninstall program will remove all registry entries and CSPro system files (that is, all files within the CSPro 7.1 folder, such as its Examples subfolder). It will not remove any applications or other files you have created.
7. When the files are removed, the installation program indicates that the process is complete. Click Finish.
1.3 Facility DV/SA CSPro application

The Facility DV/SA core questionnaire has been programmed in CSPro and is available at: http://www.who.int/healthinfo/systems/sara_introduction/en/index.html. The Facility DV/SA CSPro application can be adapted to each country context.

In this chapter, we will guide you through the file hierarchy of Facility DV/SA CSPro application, and also explain what the different files are for.

Preparing to open the Facility DV/SA CSPro application

Setting time and date on the tablets/laptops

The Facility DV/SA application uses the computer time and date in the program, so it is very important that the date and time is set correctly on the tablets to use in the field.

Create a folder to store your CSPro/Facility DV_SA files

Download the CSPro SARA + DV zip file and unpack the file CSPro SARA + DV.zip to the desktop. This creates the folder CSPro SARA + DV, in which the SARA application, Facility Data Verification application, and District Data Verification are located. We will be focusing on the CSPro SARA_2.3 folder which contains the SARA configuration and sample files and is where the data are stored and appropriately organized. When setting the Facility DV/SA survey up for the tablets to be used during the interviews, copy the shortcut “CSPro SARA + DV/CSPro Facility DV_SA/FACILITY_DV_SA.pff” – shortcut to the desktop. The interviewer can then double click on this file to start up the application.

The Facility DV/SA CSPro files structure

The Facility DV/SA file hierarchy

When unpacked, the file hierarchy of the Facility DV/SA is like this:

C:/CSPro SARA + DV/CSPro Facility DV_SA The main application to start up the Facility DV/SA survey is located here.

/Batch CSPro batch programs that are used with Facility DV/SA

/Batch_1 The batch program for data processing (completeness)

/Batch_2 The batch program to separate the supervisor validations

/Batch_3 The batch program for indicator generation

/Batch_4 The batch program to delete value sets

/Data The raw data files for the Facility DV/SA survey

/Supervisor validation The supervisor validation data files

/Lookup_files Files that are used by the application. These will be edited for each implementation of the Facility DV/SA.

When moving around in the hierarchy, you will see that there are many files. This is because CSPro generates many different kinds of files. An interviewer need not to know anything about the files or hierarchy as a shortcut
to launch the data entry application is provided for them. As an administrator of the application, however, you need to know more. There are several very important folders which you will need to be quite familiar with including the lookup folder and the data folder.

**File types in CSPro**

In the main Facility DV/SA folder, there are many files and a multitude of file types. The following is an overview of the different types of files of CSPro. It is highly recommended to configure Windows Explorer to show extensions for known file types. A folder with CSPro files becomes rather confusing without the extensions showing. To do this: Open Control panel, and in the upper right corner choose “View by small icons”. Then you can click on “Folder options”. Choose the tab “View”, and un-tick “Hide extensions for known file types” Then click OK.

<table>
<thead>
<tr>
<th>File name</th>
<th>File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FACILITY_DV_SA.dcf</td>
<td>Data Dictionary File</td>
<td>Each file manipulated by CSPro must be described by a data dictionary. The data dictionary file contains information defining the layout of the data file, including levels, records, items, value sets, and values.</td>
</tr>
<tr>
<td>FACILITY_DV_SA.ent</td>
<td>Data Entry Application File</td>
<td>The data entry application file is the master file for the data entry application. This file specifies all other files contained in the application, along with other information.</td>
</tr>
<tr>
<td>FACILITY_DV_SA.fmf</td>
<td>Form File</td>
<td>The forms file contains information about forms, their fields, text, and rosters. The forms file also contains the name of the associated data dictionary file. The flow during data entry, that is, the order in which forms and fields are entered, is defined in the forms file, not in the data dictionary.</td>
</tr>
<tr>
<td>FACILITY_DV_SA.ent.apc</td>
<td>Logic File</td>
<td>The logic file contains all the CSPro language statements which control the application. There is one logic file associated with each application.</td>
</tr>
<tr>
<td>FACILITY_DV_SA.ent.mgf</td>
<td>Messages File</td>
<td>The message file is a text file where you can store message text and an associated message number. The message is displayed when an &quot;errmsg&quot; function with the message number is executed in a data entry application. A message may contain parameters.</td>
</tr>
<tr>
<td>FACILITY_DV_SA.ent.qsf</td>
<td>Question File</td>
<td>The question file contains information related to CAPI data entry applications. Such information includes question text to appear on the screen with each field and when the operator presses the help key.</td>
</tr>
<tr>
<td>FACILITY_DV_SA.pff</td>
<td>Program Information File</td>
<td>Program information files are used to run applications or tools in production mode.</td>
</tr>
<tr>
<td>FACILITY_DV_SA.pen</td>
<td>Binary data entry application</td>
<td>A binary data entry application consists of one single file, which includes the same information as the set of text files that normally make up a data entry application. This file cannot be changed in any way nor opened by the CSPro designer.</td>
</tr>
</tbody>
</table>

**File types in the data folder**

<table>
<thead>
<tr>
<th>File name</th>
<th>File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Facility_DV_data.csdb</td>
<td>Data file</td>
<td>This is the file containing the actual data.</td>
</tr>
<tr>
<td>Facility_DV_data.csdb.log</td>
<td>Log file</td>
<td>Operator statistics</td>
</tr>
<tr>
<td>Facility_DV_data.csdb.lst</td>
<td>Listing File</td>
<td>Listing of data entry activity for each data file</td>
</tr>
</tbody>
</table>
CSPro for standalone data verification and system assessment modules
1.4 Configuring the Facility DV/SA application

The Facility DV/SA application needs to be configured before it can be used in a survey – without this configuration it will not work. Most of the configuration is about either changing csv (semi-colon separate) files, or creating new ones, and they are all to be found in the CSPro Facility DV_SA/lookup_files folder. It may also require using the configuration file and editing the .pff file. Detailed instructions for each step in the configuration process are found in the following sections.

Create the sample file

The Facility DV/SA survey accepts one, two or three geographical levels (Only region, region and district, or region, district and sub-district). The structure of the sample file (which is a csv file) decides what level the application will use.

The following tables are the structure of the sample file for each of the different levels

One geographical level

<table>
<thead>
<tr>
<th>Region number</th>
<th>Region name</th>
<th>Facility number</th>
<th>Facility name</th>
</tr>
</thead>
</table>

Two levels

<table>
<thead>
<tr>
<th>Region number</th>
<th>Region name</th>
<th>District number</th>
<th>District name</th>
<th>Facility number</th>
<th>Facility name</th>
</tr>
</thead>
</table>

Three levels

<table>
<thead>
<tr>
<th>Region number</th>
<th>Region name</th>
<th>District number</th>
<th>District name</th>
<th>Sub-district number</th>
<th>Sub-district name</th>
<th>Facility number</th>
<th>Facility name</th>
</tr>
</thead>
</table>

The columns should have no row containing headers. The following is an example of a 2-level sample file. It is optional to leave repeating fields (like for instance repeating region number or names) blank. Examples of sample files for 1 and 3 levels can be found in the lookup_files folder of the Facility DV/SA application.
CSPro for standalone data verification and system assessment modules

The sample file has to be sorted by the columns REGION ID * DISTRICT ID * FACILITY ID. This is done in excel by choosing custom sort, and then specify the sorting like this:

![Excel Custom Sort](image)

(in the case of 1 level sample file, it should be sorted on REGION ID * FACILITY ID, and in the 3 level, on REGION ID * DISTRICT ID * SUBDISTRICT ID * FACILITY ID)

When the sample file is made, remember to save it as a **semi colon separated csv file**. It has to have the name Sample.csv and to be placed in the folder CSPro SARA + DV/CSPro Facility DV_SA/Lookup_files

1. In Excel: choose File – Save as
2. In the field “Save as type”. Click on the arrow on the right to get the dropdown menu and select “CSV (MS-DOS) (*.csv). Give the file the name “Sample.csv”
3. Excel then pops up this window:
press “OK”

4. And this window:

press “Yes”.

Please note: The file has to have the name Sample.csv and be placed in the folder CSPro SARA + DV/CSPro Facility DV_SA/Lookup_files.

The application will look at the structure of the Sample.csv file, and decide from the number of columns how many geographical levels to use. If only one or two levels are in use, the application automatically makes the irrelevant fields protected, so that the users cannot input data in them.

Note: If you are implementing the Facility DV/SA survey in conjunction with the SARA survey, this sample file is the same as the sample file for the SARA survey. It does not need to be configured twice and can be copied from one application to the other once configured for either application.

Create the replacement facility sample file

The structure of the replacement facility file has to be the same as the sample file with the right number of geographical regions, and it must be named sampleReplacement.csv. It should contain a list of replacement facilities, but also a number of “empty” facility numbers for the interviewers to use if they visit facilities not on the list at all. The following is an example of a 2 geographic level replacement file:
Make sure that there are enough empty facility numbers – especially that there are some for each region and district. Also, do not duplicate the empty facility numbers. When the replacement sample file is made, remember to save it as a semi colon separated csv file. It has to have the name sampleReplacement.csv and to be placed in the folder CSPro SARA + DV/CSPro Facility DV_SA/Lookup_files

**Note:** If you are implementing the Facility DV/SA survey in conjunction with the SARA survey, this replacement file is the same as the replacement file for the SARA survey. It does not need to be configured twice and can be copied from one application to the other once configured for either application.

### Create the interviewer ID file

When running Facility DV/SA application, the application asks for the ID number of the interviewer. This is a two digit number assigned to uniquely identify each interviewer or interviewing team. Below is an example of how the interviewer number question is displayed in CSPro:

The information about the interviewers and the assigned ID number has to be saved in the file CSPro SARA + DV/CSPro Facility DV_SA/Lookup_files/listOfInterviewers.csv, and it has to have following format:

01;Team 1
02;Team 2
03;Team 3
Configure the DV module selection

The Facility DV/SA questionnaire includes a number of modules that can be selected. The survey manager and steering committee will select which modules are to be included in the survey. The CSPro application must be configured to reflect this decision at country level.

To leave out a module, open the file `CSPro SARA + DV/CSPro Facility DV_SA/Lookup_files/ListOfDvModules.csv` in either Excel or a text editor and delete the rows containing the modules that are not to be included in the survey.

Adding new DV modules

This paragraph assumes that the responsible knows enough CSPro to make the new records and forms needed for the DV module to be added.

First a record must be added to the dictionary that contains the additional questions to be added. There are no requirements for where the record must be placed.

After the record has been created and the fields added to it, all the country specific items have to be placed in the `DV_COUNTRY_SPECIFIC_FORM`. Also, this form has to be listed in the lookup file `ListOfDvModules.csv`.

Specify DV reporting months

To specify what reporting months to use in the DV modules, open the file `CSPro SARA + DV/CSPro Facility DV_SA/Lookup_files/DvReportingMonths.csv` in either Excel or a text editor.

This file should only contain the three months of reporting in the order oldest to newest separated by a semicolon. The survey manager and steering committee should be consulted to determine which months will be assessed. Generally, it is the last three complete months for which reporting is expected to have occurred.

Change the display language

The Facility DV/SA survey has been designed to be used both in English and French speaking countries, and new languages can easily be added. The information about what language to use is taken from the file that starts up Facility DV/SA application: the `FACILITY_DV_SA.pff` which is on the root of the CSPro Facility DV_SA folder.

The default language is English, and if French is to be used, the pff file has to be edited:

1. Open `FACILITY_DV_SA.pff` in a text editor of your choice (for example by searching for notepad in the start menu and then open it from notepad (remember to choose the option “all files (*.*) next to the file name field))

2. Change the last line of the file so that it becomes

   Parameter=FRA;2000;NOQUIT

3. The ENG;1000/FRA;2000 portion of the command refers to the language. This is followed by a command NOQUIT which tells the application to return to the main menu after a facility record is complete. If you
remove “NOQUIT” from this line, CSEntry will shut down once a case is complete and will need to be restarted from the pff to enter a new facility.

4. Save and exit.
1.5 Getting to know CSPro

Start CSPro and open the Facility DV/SA application

Now you are ready to start the Facility DV/SA application using CSPro:

1. Double-click on the desktop’s CSPro 7.1 icon or select All Programs -> CSPro 7.1 -> CSPro 7.1 from the start menu

2. Select Open an existing application and double click on ...other files to browse to FACILITY_DV_SA.ent file.

3. Alternatively, you can double click on the FACILITY_DV_SA.ent file.

4. The Cover page of the Facility DV/SA data entry application opens. The screen is subdivided into two parts: the left part displays a files tree; the right part corresponds to the application.
Explore the data entry application

The workspace
The CSPro workspace is divided into two parts: the left is reserved to display file trees; and the right window is reserved to display the actual application.

Trees
Trees are displayed in the left part of the screen and they present the relationship between the different files.

There are three types of trees, corresponding to the three tabs at the bottom part of the left screen (See red outline): the Files tree (Files), the Dictionary tree (Dicts) and the Forms tree (Forms).

- Files: The Files tree shows all the data entry applications that are open, and the files they contain.
CSPro for standalone data verification and system assessment modules

- Dicts: The Dictionary tree shows all the dictionaries the application is using, and their contents.
- Forms: The data entry forms tree shows all the forms for the opened application. When clicking on the plus sign in front of a form, the items of the given form is also shown.

One can navigate from one tree to the other by clicking on the tab of interest (marked with a red ring above).

In the above picture, the actual names of each of the fields of the form is displayed in the tree (For instance Q010). This is sometimes helpful, but sometimes you need to know more about the field. To alternate between showing the name or the label of the items in the tree, click on View/Names in tree (or use Ctrl+T).

**Window**

The window on the right side of the screen allows you to modify the contents of a dictionary or a form. Each different window has different functions associated with it (different menu and toolbar). When opening an existing application, CSPro displays the first form of the application as default (as shown above). To see the workspace for the dictionary instead, click on the dictionary icon above the workspace.

**Toolbars**

**Menu toolbar**

The menu bar includes features common to most Windows applications plus some that are unique to CSPro.

**Data Dictionary toolbar**

The Data Dictionary toolbar is displayed across the top of the window, below the menu bar. It provides quick mouse access to many features used in the Data Dictionary. It is available whenever the right-hand screen is displaying dictionary items. If the right-hand screen is not displaying dictionary items, click on the dictionary icon on the toolbar.

The table below provides a description of the function of each icon in the data dictionary toolbar.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Create a new dictionary]</td>
<td>Create a new dictionary</td>
</tr>
<tr>
<td>![Open a dictionary]</td>
<td>Open a dictionary</td>
</tr>
<tr>
<td>![Save a dictionary]</td>
<td>Save a dictionary</td>
</tr>
<tr>
<td>![Set up page margins and headings for printing]</td>
<td>Set up page margins and headings for printing</td>
</tr>
<tr>
<td>![Preview contents of the dictionary]</td>
<td>Preview contents of the dictionary</td>
</tr>
<tr>
<td>![Print contents of the dictionary]</td>
<td>Print contents of the dictionary</td>
</tr>
<tr>
<td>![Undo the last change to dictionary]</td>
<td>Undo the last change to dictionary</td>
</tr>
<tr>
<td>![Redo last undo]</td>
<td>Redo last undo</td>
</tr>
<tr>
<td>![Cut the selected records, items, or values to the clipboard]</td>
<td>Cut the selected records, items, or values to the clipboard</td>
</tr>
<tr>
<td>![Copy the selected records, items, or values to the clipboard]</td>
<td>Copy the selected records, items, or values to the clipboard</td>
</tr>
<tr>
<td>![Paste the contents of the clipboard to the current position]</td>
<td>Paste the contents of the clipboard to the current position</td>
</tr>
<tr>
<td>![Add levels, records, items, values sets, or values]</td>
<td>Add levels, records, items, values sets, or values</td>
</tr>
<tr>
<td>![Insert levels, records, items, values sets, or values]</td>
<td>Insert levels, records, items, values sets, or values</td>
</tr>
<tr>
<td>![Delete levels, records, items, value sets, or values]</td>
<td>Delete levels, records, items, value sets, or values</td>
</tr>
<tr>
<td>![Edit Notes for dictionary, level, record, item, value set, or value]</td>
<td>Edit Notes for dictionary, level, record, item, value set, or value</td>
</tr>
</tbody>
</table>
The Forms Designer toolbar

The forms designer toolbar is displayed across the top of the window, immediately below the menu bar. The toolbar provides quick mouse access to many of the often-used features found in the Forms Designer. It is available whenever the right-hand screen is displaying forms. If the right-hand screen is not displaying forms items, click on the forms icon on the toolbar.

The table below provides a description of the function of each icon in the forms designer toolbar.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Create a New application" /></td>
<td>Create a New application</td>
</tr>
<tr>
<td><img src="image" alt="Open an application" /></td>
<td>Open an application</td>
</tr>
<tr>
<td><img src="image" alt="Save an application" /></td>
<td>Save an application</td>
</tr>
<tr>
<td><img src="image" alt="Compile the logic (code) of your data entry application" /></td>
<td>Compile the logic (code) of your data entry application</td>
</tr>
<tr>
<td><img src="image" alt="Run the current data entry application (i.e., start-up CSEntry)" /></td>
<td>Run the current data entry application (i.e., start-up CSEntry)</td>
</tr>
<tr>
<td><img src="image" alt="Undo the latest changes" /></td>
<td>Undo the latest changes</td>
</tr>
<tr>
<td><img src="image" alt="Redo the latest changes" /></td>
<td>Redo the latest changes</td>
</tr>
<tr>
<td><img src="image" alt="Cut the selected elements to the clipboard" /></td>
<td>Cut the selected elements to the clipboard</td>
</tr>
<tr>
<td><img src="image" alt="Copy the selected elements to clipboard" /></td>
<td>Copy the selected elements to clipboard</td>
</tr>
<tr>
<td><img src="image" alt="Paste the contents of the clipboard to the form" /></td>
<td>Paste the contents of the clipboard to the form</td>
</tr>
<tr>
<td><img src="image" alt="Delete the currently selected item(s)" /></td>
<td>Delete the currently selected item(s)</td>
</tr>
<tr>
<td><img src="image" alt="Find text in logic" /></td>
<td>Find text in logic</td>
</tr>
<tr>
<td><img src="image" alt="Toggle between selecting item(s) or drawing boxes" /></td>
<td>Toggle between selecting item(s) or drawing boxes</td>
</tr>
<tr>
<td><img src="image" alt="View the forms" /></td>
<td>View the forms</td>
</tr>
<tr>
<td><img src="image" alt="View the logic" /></td>
<td>View the logic</td>
</tr>
<tr>
<td><img src="image" alt="View the CAPI question" /></td>
<td>View the CAPI question</td>
</tr>
<tr>
<td><img src="image" alt="Show last Dictionary window" /></td>
<td>Show last Dictionary window</td>
</tr>
<tr>
<td><img src="image" alt="Show last Forms window" /></td>
<td>Show last Forms window</td>
</tr>
<tr>
<td><img src="image" alt="Get Help" /></td>
<td>Get Help</td>
</tr>
</tbody>
</table>
1.6 Modifying the Facility DV/SA application

The Facility DV/SA survey is a full package consisting of the questionnaire and data entry application and batch edit applications to process the data. All of the parts are dependent on each other. It is therefore not recommended to modify the application extensively. However, there may be a limited number of country specific changes that will need to be made. This section explains how to make basic edits to the Facility DV/SA application.

Modify a dictionary item

The CSPro dictionary contains one item for each question in the questionnaire. If adaptations have been made to the paper questionnaire, such as the addition or deletion of a question, they must also be made to the CSPro dictionary and the forms in CSPro.

Add a dictionary item to a dictionary

1. Look at the tree on the left side of the screen and make sure dictionary is selected. If not, click on the dictionary tab ( ). The screen should look something like this:

2. Decide what module the new dictionary item belongs to (say DV_ANTENATAL_CARE). In the tree view on the left side, all of the modules are visible (one module in the paper questionnaire correspond to one record in the tree view). Click the relevant module.

3. Look at the window on the right side of the screen and make sure dictionary items are showing. If not click on the dictionary icon on the toolbar.

The screen should now look something like this:
4. We will be adding the following question to the CSPro dictionary:

<table>
<thead>
<tr>
<th>Number</th>
<th>Question</th>
<th>Result</th>
<th>Skip</th>
</tr>
</thead>
<tbody>
<tr>
<td>XX_1</td>
<td>Which of the following reporting systems does this facility report ANC data to:</td>
<td>YES .............................................</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Faith based institutions</td>
<td>NO ..............................................</td>
<td>2</td>
</tr>
</tbody>
</table>

5. In the right-hand window of CSPro, right click on the dictionary item below where you would like to add a dictionary item. For this example, we want the new item between the elements DV_102_03 and DV_102_04, hence right click on DV_102_04. Select insert item. Now fill out the following fields. Use the tab key to move between columns.

- **Item Label**: A descriptive label which identifies this record. For this example, use the label ANC reporting system: Faith based institutions
- **Item Name**: The name given to this record for use in the CSPro language procedures. For the Facility DV/SA survey, we will use the question number as the item name. For this example, we will use XX_DV_1.
- **Start**: Indicates the starting position of the item within the record. This box should automatically fill in and does not need to be changed.
- **Len**: Indicates the length of the data item (i.e., the number of characters necessary to represent the values for the item). This should be the same as the number of digits in the response code, in this example 1.
- **Data type**: Indicates the type of data (numeric or alphanumeric) that will be found in the item. For this example, the choice should be Numeric.
- **Item type**: Indicates whether the item is or is not subordinate to, or part of, another item. If the item is part of another item, it is considered a "subitem". If not, it is identified as an "item". Identification items cannot have subitems. For the Facility DV/SA questionnaire, use the default option of Item.
- **Occ**: The number of times this item will repeat within the record. The default value is "1". Identification items cannot have multiple occurrences. For the Facility DV/SA questionnaire, use the default number, 1.
- **Dec**: The number of decimal places (if any) in the item. The default number of decimals is "0". Identification items cannot have decimals. For the Facility DV/SA questionnaire, use the default number, 0.
CSPro for standalone data verification and system assessment modules

- **Dec Char:** This specifies whether the item should be stored in the data file with an explicit decimal character. This applies only to items or subitems which have been defined with the "Dec" property greater than zero (i.e., Dec >= 1). For the Facility DV/SA questionnaire, use the default option of No.

- **Zero fill:** This item property states whether the numeric data item should contain leading zeros or blanks. For the Facility DV/SA questionnaire, use the default option of No.

When all fields are complete, click anywhere in the window to complete the item entry. The result should be a new dictionary item that looks like the following:

6. Go to File -> Save or Ctrl+S to save your work thus far.

**Note:** When adding a new question, be sure to add a new question number. Each question corresponds to a particular indicator and changing the question numbers will affect the measurement of a given indicator. Do not change the existing numbering scheme. Instead add a country specific question number to all new questions.

A value set contains the numeric responses that are given to each item, and are used to define ranges of valid values during data entry. These should correspond to the response options and response codes provided in the paper version of the questionnaire.

As the Facility DV/SA application can be used for both English and French speaking countries, the value set naming should follow a predefined standard to facilitate this: The value sets containing English texts should be post fixed with _ENG, while the French with _FRA.

To access the area where value sets can be edited in CSPro, click on the dictionary icon on the toolbar on top of the CSPro window. By clicking on the items within the records in the tree view, you will get access to the value sets.
We are going to add a value set to the previously added dictionary item “ANC reporting system: Faith based institutions” – or DV_XX_1.

7. Make sure you have the dictionary view in the right part of the display of CSPro by clicking on the dictionary item on the toolbar.

8. Expand the DV_ANTENATAL_CARE record (click on the plus sign in front of it), and click on the DV_XX_1 item to highlight it.

9. Right click in the right window and select Add Value Set.
10. Press Enter to accept the default Value Set Label and for Value Set Name, enter DV_XX_1 ENG and enter. The cursor will drop to the line below into the Value Label column. Remember, the Value Set Label is a descriptive text label, and the Value Set Name identifies the item for use in CSPro procedures.

11. The Value label column corresponds to the descriptive text for a single value. In the Facility DV/SA questionnaire this is the text of a response's options. For example, a question that has "Yes" or "No" as pre-defined response options should have "Yes" and "No" as the Value labels. If the question response does not have a pre-defined answer, such as for "Number of maternity beds", leave the Value label blank. The "From" and "To" columns define the range of possible values for that question's response.

The "From" column is for the single value, or starting value of a range associated with the Value label. The "To" column is for the upper limit of the range of values being defined. It must always be greater than the "From" value on the same line. Where only a single value is associated with the Value Label, the "To" value may be blank.

For this example we will enter Yes, 1 and No, 2 for the "Value Label" and "From" columns, leaving the "To" column empty. Your screen should look like the following after entering the value set:

12. Go to File -> Save or Ctrl+S to save your work thus far.

Edit an existing value set

We want to add a value “9 – do not know” to the value set just created above for ANC reporting system: Faith based institutions DV_XX_1:

1. Make sure the dictionary view is displayed. If not: click on the dictionary item on the toolbar of CSPro.

2. Expand the DV_ANTENATAL_CARE record and click on the item DV_XX_1 to highlight it.

3. Right click somewhere on the value set, and choose “Add value” (This will add the value at the end of the value set. If you want it in somewhere in the middle right click on the item under where you want it, and choose "insert value")

4. Enter the text “Do not know” in the Value label field, and “9” in the From field.
5. Go to File -> Save or Ctrl+S to save your work thus far.

If you want to change either the label or the value of an existing value in the value set: Right click on the value, and choose “modify value”. Enter either the new label or the new value.

**ADDITIONAL NOTES ON CHANGING VALUE SETS**

For some value sets, the length of the response may change. If the number of digits in the response changes, you will need to adjust the length filed of that item in the dictionary.

For a question in which the response is numeric, such as the "Number of ANC visits", the **Value label** can be left blank, and the "From" and "To" columns should contain the minimum and maximum response values, in this case 0-999.

For items which refer to an instruction, such as the instruction introducing "ANC reporting system instruction", the **Value label** should be "continue", and the "From" column "1", leaving the "To" column blank. This will allow the interviewer to read the instruction and then click on continue to move to the next question.

Value sets can be copied and pasted if the same response options apply to multiple questions. To copy a value set, right click on the value set in the right portion of the screen and select **copy** (note: you can copy several value sets by highlighting them prior to copying them). Then click on the item from the left side of the window where you would like to paste the value set. In the window on the right side, right click and select **paste**.

**Add a newly created dictionary item to the form**

After adding a dictionary item to the dictionary, it must then be added to the form. When opening the form (click on the form icon on the toolbar), you will see that the new item is not added to the form. The next step is to add the item to the form.

1. Make sure you have the form visible on the right side of the CSPro window, and the dictionary in the tree view on the left (Click on the dictionary item on the bottom left part of the screen). In the tree view, it is easy to see what elements that have not been used in the form, as they have the icon marked turquoise (see the yellow highlight below).
2. Use the mouse to drag the item on to the forms canvas and place it where you want it. It should appear in the same order as is listed in the dictionary.

- Click and drag the mouse from above DV_102_04 and all the way down to under the last item, marking them all:

- Now you can use the mouse to drag down the highlighted items to make space for the new item.

- Place the new item between DV_102_03 and DV_102_04.

- Right click on the response box for the new item and select field properties. Click on the button next to capture type and change from radio button to text box. The click ok on the open screens. The Facility DV/SA survey uses text box and number pad as the only capture types.
The order of the questions when the application is running is the same as the order of the items displayed in the forms tree (click on the forms tab in the lower left part of CSPro):

Hence the new item is going to be asked at the very end of this section – even if it does not look this way on the form where we put it higher up.

To have it asked in the right order, grab it with the mouse in the tree view, and drag it up to the right place in the tree:
Adding the CAPI question

Notice that the icon of DV_XX_1 in the tree view is different from the other icons: It does not have a question mark like the others. This is because no CAPI question is defined for this item. To add the CAPI question text:

1. Click on the CAPI question icon on the tool bar on top of the screen.

2. Make sure the DV_XX_1 item is highlighted in the tree view, and write the question in the upper text box on the right window:

3. Mark the text just written with the mouse, and select the button F1 (Capi font 1) to make it have the same size and font as the other questions.
4. If you would like to add text in French, type the text in the lower text box in the CAPI window.

5. In addition to question text, a CAPI application can have help information for each question. During entry, the F2 key is used to display a question’s help text. The text for the help section should come from the SARA Interviewer’s guide to the core questionnaire which contains instructions, definitions, and pictures for questions in the questionnaire. We will add the following text to the help section for the ANC reporting question:

ANC reporting to a faith based institution system means reports are sent on a regular basis to a faith based managing authority.

Switch from editing question text to editing help text by pressing the button, or by choosing Help Text from the CAPI Options menu.

6. Type in the above help text into the upper editing window on the right-hand window. If you would like to add text in French, type the text in the lower text box in the CAPI window.

7. Go to File -> Save or Ctrl+S to save your work thus far.

Delete a dictionary item

Delete the dictionary item from the dictionary

Say that we want to delete the item we just added – the DV_XX_1 item in the section DV_ANTENATAL_CARE.

1. Look at the tree on the left side of the screen and make sure dictionary is selected. If not, click on the dictionary tab.

2. Look at the window on the right side of the screen and make sure dictionary items are showing. If not click on the dictionary icon on the toolbar.

3. Click on the DV_ANTENATAL_CARE record to activate the dictionary items for this record in the right side window.

4. In the right-hand window, right click on the dictionary item labelled “ANC reporting system: Faith based institutions” (the name of the item, DV_XX_1 is in the second column) and click on delete item. The item has now been removed from the data dictionary.

Cleaning up the form after deleting a dictionary item

The item will automatically be removed from the form, but some cleaning up might be needed.

1. Click on the forms icon on the toolbar. CSPro will then give this message:
The CSPro language lets you write programming logic for your Data Entry and Batch Edit applications. In Data Entry applications you can write logic to control and check the keying operation as it progresses. In Batch Edit applications you can write logic to identify and correct errors after data capture is complete. CSPro logic consists of a collection of events defined as procedures. Each procedure performs the operations you specify using CSPro statements and functions written in the CSPro Language.

Logic has already been programmed into the CSPro application for the Facility DV/SA questionnaire. If you have made changes to the questionnaire, you may also have to make changes to the logic. These changes will be specific to the questions changed. Below are several examples of how to change the questionnaire logic.

**Skip pattern**

For this example, we will insert logic into the data entry application for the antenatal care section. In question DV_102_04 we ask whether any other ANC reporting system is in place, and in question DV_102_04A we ask to specify what the other system is. The latter question should only be asked to the facilities that answered yes to the first question, hence we want to skip DV_102_04A if the answer to question DV_102_04 is no.

1. Open the FACILITY_DV_SA.ent file.

2. Look at the tree on the left side of the screen and make sure forms is selected. If not, click on the forms tab.

3. Look at the window on the right side of the screen and make sure a form is showing. If not click on the forms icon on the toolbar.

4. Click on the logic icon on the toolbar, or select **View/View Logic** from the main menu (or press Ctrl+L).

5. Go to **View** menu and select **Names in tree** (or press Ctrl+T) to show names instead of labels in the forms tree. You can toggle between names and labels at any time to make sure that you are working with the correct items.

6. Click on DV_102_04 in the **Forms** tree. The frame on the right hand side of the screen should show "PROC DV_102_04" at the top. Note that "PROC" is short for procedure and DV_102_04 is the item name.

---

Note: Each question corresponds to a particular indicator and removing a question will affect the measurement of a given indicator and the analysis of results from the survey. Please be cognizant of this when deciding to remove a question.

In addition, if you delete anything from the dictionary, you will have to delete any associated programming. This will be discussed later on, but it important to keep note of what has been deleted.
corresponding to the question which asks for the type of the facility. We put our logic in the procedure for
DV_102_04 because we want it to execute immediately after the operator keys this field.

7. In the text editor, at the top of the logic view, type in the logic exactly as you see it below (the first line
reading "PROC DV_102_04" will already be displayed - do not repeat this text):

```csp
PROC DV_102_04
if $ = 2 then
    DV_102_04A = ""
    skip to INS_DV_103;
endif;
```

(Notice the use of semi colons at the end of each statement except from the PROC statement in the beginning.
A semi colon tells CSPro that the instruction is finished. In the example above, the instruction starting with "if"
is not really finished until after "endif", while the “skip to..” instruction is finished at the end of that line.)

This logic code in CSPro language states that if the response for item number PROC DV_102_04 is 2, then make
sure DV_102_04A is blank and skip to DV_103.

Your screen should look like this:

8. Go to File -> Save or Ctrl+S to save your work thus far.

A note about programming skip patterns: if the logic is typed in directly after the PROC statement, the default
is that the logic will be applied AFTER the question is answered. If you would like the logic to be applied
BEFORE a question is answered, you must type preproc after the PROC statement.
Logic to display error messages

As mentioned earlier, SARA is designed for using both English and French. Hence the error messages have to be in both languages as well. To know what language is currently in use, we have a variable MSG_LANG which is set to be 1000 if the language is English and 2000 if it is French.

In the statement:

```plaintext
ermsg(MSG_LANG + 999);
```

MSG_LANG + 999 becomes 1999 if the language is English, and 2999 if it is French, so the statement simply means “show error message number 1999” (or 2999)

To see all error messages – or create new ones, click on the “Message” tab on the bottom for the CSPro window:

Let us make a new error message for the field DV_XX_1 that pops up if the interviewer chooses “No” (value 2)

1. Look at the tree on the left side of the screen and make sure forms is selected. If not, click on the forms tab.

2. Look at the window on the right side of the screen and make sure a form is showing. If not click on the forms icon on the toolbar.

3. Click on the logic icon on the toolbar, or select View/View Logic from the main menu (or press Ctrl+L).

4. Click on DV_XX_1 in the Forms tree. The frame on the right hand side of the screen should show "PROC DV_XX_1" at the top. Put the logic in the procedure for DV_XX_1 because we want it to execute immediately if the operator leaves the field blank.
5. In the text editor, at the top of the logic view, type in the logic exactly as you see it below (the first line reading "PROC DV_XX_1" will already be displayed - do not repeat this text):

```
PROC DV_XX_1
  if DV_XX_1 = 2 then
    errmsg(MSG_LANG + 35);
    reenter;
  endif;
```

This logic code in CSPro language states that if the response for item number DV_XX_1 is 2, an error message having the message number 1035 (or 2035) will be displayed and the cursor will be placed back into the DV_XX_1 response field so that the data entry personnel can re-enter the field.

6. The error message must also be entered in the message field: Click on the message tab, and type:

1035 Please check again whether the institution reports to a faith based system

The screen should look like this:

7. Go to File -> Save or Ctrl+S to save your work thus far.

**Compile logic**

In the previous two steps, logic has been entered in CSPro language. Like all procedural languages, the system must check these to make sure there are no syntax errors. This is called "compiling". Once all logic changes have been entered, the CSPro application must be compiled. To do this, use the following steps:

1. Click on FACILITY_DV_SA_FF at the very top in the Forms tree to show all the CSPro logic.
2. Compile the logic by clicking on the toolbar, or select File/Compile from the main menu (or press Ctrl+K).

3. If you typed the logic correctly, you will see Compile Successful in the Compiler Output under the logic.

4. If you see a dialog box that says Compile Failed, you have typed something incorrectly. A red circle will appear in the margin indicating the approximate location of the error. The Compiler Output tab at the bottom of the screen will show you an error message to help you determine the error. Check very carefully to make sure you typed in exactly what was shown in the previous tasks.

5. The screen should look like this:

6. Go to File -> Save or Ctrl+S to save your work thus far.

7. Test the logic by running the application and select 2 in the field DV_XX_1. The following error message should be displayed:

   ![Error Message]

   Please check again whether the institution reports to a faith based system

   OK

8. Also check if the skip in the question DV_102_04 works: Select “2 No” when answering. The question DV_102_04A should now be grey and not possible to fill out, while the cursor is now at INS_DV_103:
9. When you are finished testing the logic, press the cross at the top left corner to quit the application. If you are at the beginning of a case or have not made any changes, the session will end immediately. If you have started, but not completed entry/modification/verification of a case, the following choices will be available.

- Partial Save: Partially save the changes you have made so far and remember the field you are on, so you can complete the work later.
- Finish: Finish the data entry and save the modifications you have made. Available only in Modify mode.
- Discard: Discard all the changes you have made since you opened this data entry application. Always available.
- Cancel: Cancel this operation and return to entering the data. Always available.

For this example, we will select discard.

**Add a new record and form to the Facility DV/SA application**

Adding a new record and form should be done with care, as it might destroy the skip patterns that are already in place. For this section, we will assume we are going to add a record about malaria.

1. Open CSPro and make sure to have the dictionary view (Click on this icon on top of the window: 📒 to enter dictionary view). Click on the DVQUEST in the left pane to get an overview of all the records in the right pane:
2. Decide where you want the new record to be, right click on the line right under it, and choose “Insert Record”. Enter the label and name of the new module.

3. In the left pane, click on the record just created. The right pane then becomes almost blank – just containing the ID elements which are not editable in this part of the dictionary. Right click somewhere in the right pane, and choose “add item”. Add each question that is to be in the record as described above. Do not forget to add value sets too.

4. When the record is added to the dictionary. Click on the icons for the forms view, both on top on the window, and on the bottom left. Right click on the DV_QUEST and choose “add form”. Give the form the same label as the label of the record in the dictionary. The name should be the same as the label of the record, but ending with “_FORM”. The new form is added at the end of the list of all the forms in the left pane.

5. Click on the newly created form in the left pane to get it displayed in the right pane. The screen should look like this:
6. Click on the Dicts icon in the bottom left, and drag the record just created onto the “canvas” to the right. Arrange the fields as desired.

7. In the left pane, move the form up to where you want it to be in the questionnaire. Add logic and CAPI questions as described above. Check that the record right before this new one does not have any skips that takes focus past the new module. If so, change them to skip to the first item in the new record.
1.7 Run the data entry application

Check the settings

1. Open the FACILITY_DV_SA.ent file.
2. Make sure the forms tab is active. On the menu toolbar, select Options -> Data entry.
3. The recommended settings for the CSPro application are as below:

![Data Entry Options](image)

Make sure the above options are selected.

**TYPE: OPERATOR VS. SYSTEM CONTROLLED**

CSPro offers two distinct types of data entry applications. Your choice will determine certain behaviours at data entry time. Some special data entry keys will behave differently.
• Operator controlled: This is the default type of data entry application. This type generally allows more flexibility for the interviewer during data entry and is recommended for simple ad-hoc applications. Operator-controlled applications have the following features:

- Some special data entry keys are active during data entry.
- CSEntry will not keep track of the path.
- "Not applicable" values will be allowed.
- More appropriate to the heads-down methodology.
- Operator can bypass logic in the application using special keys.

• System controlled: These applications generally place more restrictions on the data entry operator. This type is used for complex survey applications and is recommended for SARA data entry on PDAs. System controlled applications have the following features:

- Some special data entry keys are not active during data entry.
- CSEntry will keep track of the path.
- "Not applicable" values will not be allowed.
- More appropriate to the heads-up methodology.
- Logic in the application is strictly enforced; operator cannot bypass or override.

CONFIRM END OF CASE

Checking this box will prompt the operator to accept the case at the end of each case entered.

PARTIAL SAVE

CAPI applications can be developed so that they support partial save. This allows the interviewer save an incomplete questionnaire, and then return later to complete it. To select this option, check the box Allow Partial Save.

Note: When you reopen a partially saved questionnaire, CSPro will ask whether you would like to return to the last place that data was entered or start at the beginning.

SHOW CASE TREE

Checking this box will allow the operator to see a tree on the left showing each item in the case currently being added, modified, or verified and its value.

CAPI MODE

Checking this box will display the Computer-Assisted Personal Interviewing (CAPI) window. The top part is for question text (to be read during the interview); the bottom is for the normal form content.
Review forms

Switch to the form view to see how your questions are displayed by selecting Form from the View menu. In the Form view, you can see the questionnaire you have developed. Review to ensure that all question text and help text has been added and that the forms follow the Facility DV/SA paper questionnaire forms.

Run the application on a computer with Windows operating system

1. Your data entry application is now ready to run. If you are using a synchronization system and if changes are made to the data entry system after the synchronization is set up, the entire system will have to be copied and pasted into each device folder.

2. CSEntry is the name of the program that runs this application, allowing you to key in data. Start the application by double clicking on the FACILITY_DV_SA.pff file which should be a shortcut on the desktop of all data collection devices.

3. If no data has been entered before, a new form (case) opens. You can now start filling in the Cover page information:

The question text is located in the yellow top window. For each question, a pop-up window will appear. Select your answer and validate your choice by clicking on the right arrow (or press the ENTER button).

4. If data already exists, CSPro starts the data entry program like this:

and you can choose between modifying an existing case (by double clicking on the ID element in the case tree to the left) or add a new case by clicking on this icon: (or type ctrl-A)
5. If something happens in the middle of a data entry so that it cannot be finished, stop data entry by pressing on the red X in the upper right corner of the window. You will then get this question:

Choose “Partial save” to save what you have done so far, while “Discard” does not save the data. “Cancel” takes you back to the data entry.

6. To partially save the file while you are still collecting data, go to File/Save partial case.

7. The following pop-up window appears. Click “Ok” to continue the data entry.

*Remember to save regularly while filling in the case to avoid any data lost.*

8. To review or finish up a questionnaire not finished during the previous visit, start up the FACILITY_DV_SA.pff as in the previous paragraph:

In the left pane, there is a list of all the facilities visited so far. Choose the one you want to review by double clicking on the facility number.

**Preparing the application to run on a tablet with an Android operating system**

1. To configure the data entry application for synchronization, click on Options -> Synchronization. The following menu opens:
2. Review the sync specifications to ensure the correct settings have been selected for the Facility DV survey.
   - Synchronize main data file: This setting determines how the main data file is synchronized. There are three options:
     a. Upload changes to server: Only data that is modified on the device will be sent to the server. This is the option that will be used for Facility DV. No data will be downloaded from the server. This is the most common option for interviewers when all interviewers will work on unique assignments.
     b. Download changes from server: Only receive modified data from the server. Do not upload local changes. This might be used for a supervisor who wants to see what changes interviewers have made but does not want to make changes themselves.
     c. Sync local and remote changes: Send local changes to the server and download changes from the server. This option can be used when multiple interviewers need to work on the same assignments. Note that if both interviewers modify a case at the same time, one will overwrite the changes made by the other.
   - Download application files: Check this box if you want to download the .pen and .pff files from the server to the local device in order to support application updates in the field. For Facility DV, this box should be checked if you are going to be manually syncing tablets. If you are going to use the Deploy application to sync tablets, this option does not need to be checked.
   - Path to application on server: Specify the path on the server where the latest versions of the .pen and .pff files are stored. This is used only if the above option is checked. For Facility DV, the path specified will be /CSPro/DataSync/FACILITY_DV_DICT/app. If you are going to use the Deploy application to sync tablets, this option can remain blank.

Note: Simple, manual synchronizations do not support synchronization of external dictionaries or files other than the .pen and .pff files. To implement these advanced synchronization scenarios, you can create your own synchronization routines using logic functions or use the Deploy application to synchronize the application.

3. When the sync specifications are complete, click on OK to save changes and exit.

4. Next if using the manual synchronization option, a .pen file will need to be generated from the data entry application. If not already open, open the FACILITY_DV_SA.ent file located at CSPro SARA + DV/CSPro FACILITY DV_SA. Click on File -> Publish Entry Application (.pen). Save as FACILITY_DV_SA.pen in the CSPro FACILITY DV_SA folder.

5. The following message may appear:

   ![Confirm Save As]

   Click yes.
1.8 Set up data synchronization

If an internet connection is available to data collectors while in the field, a synchronization system can be set up so that the data can be transmitted from the data collectors to the central survey team on a regular basis. The advantage of setting up a synchronization system is that all data can be tracked and reviewed in real time by the survey data management team and feedback can be provided to the data collectors so that any mistakes can be corrected while data collectors are still in the field. In addition, if any mistakes are discovered in the data entry application once data collection begins, these can be corrected and the application re-deployed to all electronic data collection devices without requiring data collectors to return from the field. The steps for synchronization using Dropbox are presented here for both Windows and Android operating systems. Other mechanisms for synchronizing are possible, but for the Facility DV/SA survey we will concentrate on using Dropbox.

Set up Gmail and Dropbox accounts for the survey

The first step in the synchronization process is to create a Dropbox account for the survey. An email address is required for this process as well. Please take the following steps to set up the relevant accounts:

Note: If you are implementing the Facility DV/SA survey in conjunction with the SARA survey, you only need to set up one Gmail account and one Dropbox account. The single account can be used for both surveys.

1. Go to [www.gmail.com](http://www.gmail.com) and click on create an account.

2. You will need to enter First Name, Last Name, Username, password, birthday, and gender. I generally use the following for these items:
   - First Name: Country
   - Last Name: FacilityDV
   - Username: CountryFacilityDVYear
   - Password: FacilityDVYearCountry (or something else of your choosing)
   - Birthday: Jan 1, 1990
   - Gender: select one

3. This will create your survey Gmail address. You can continue to Gmail to open the email account.

4. Go to [www.dropbox.com](http://www.dropbox.com) and click on create a new account.

5. Enter First name, Last name, the email address just created in Gmail ([CountryFacilityDVYear@gmail.com](mailto:CountryFacilityDVYear@gmail.com)), and a password (FacilityDVYearCountry or something else of your choosing). Then click on agree to the terms and create an account.

6. This may prompt you to download Dropbox installer. This is not required for the Facility DV/SA sync. Navigate to the Dropbox homepage and you will be able to see what files are on the Dropbox.

7. Click on Files -> New folder and name the folder “CSPro”. Then click on share next to this new folder name.

8. A message will pop-up asking you to verify the new Dropbox account through email. Click on send email.
9. Return to your survey Gmail account. Check your inbox and click on the link in the email received from Dropbox to verify your email address. If you can’t find it, check your spam folder or ask Dropbox to resend the email.

10. Dropbox should now show display a message that your email address has been verified and you can now share folders. Once again, click on share next to the new folder (CSPro) you created in Dropbox.

11. Select invite people to collaborate, enter the email address of the survey data manager, and click share folder.

12. The data manager should now be able to login to their own personal email and accept the folder invitation. Please limit the number of people invited to this folder as anyone who has access to this folder will be able to view, edit, and delete the data entry application and the data during and after the data collection process.

**Synchronization with Android tablet**

There are two options for syncing with Android tablets: 1- Use the Deploy Application tool in CSPro and 2- Package applications for manual transfer to tablets.

**Synchronize with the Deploy Application tool**

The application deployment tool is used to package and upload CSPro applications to a server for deployment over the Internet to mobile devices. When deploying an application to multiple mobile devices it may be easier to install the application over the Internet rather than by connecting each device to a computer using a USB cable to copy the application files to the mobile device. The application deployment tool facilitates this by creating and uploading application deployment packages to a server. Once the package is on the server, users of CSEntry on a mobile device can download and install the package by choosing Add Application on the mobile device.

1. Select All Programs -> CSPro 7.1-> Deploy Application from the start menu.

2. Enter a name and description for your package (i.e. Facility:DV_SA, Facility Data Verification and Systems Assessment)

3. Drag and drop your application files and folders onto the files tree to add them to the deployment package. The file tree should look like the following:
4. Once all the files have been uploaded Select Dropbox as the server to Deploy to and then click on Deploy.

5. You will be asked to log-in to your Dropbox account. Please enter the email and password for the Dropbox account created for the survey. You should get a message that the application deployed successfully such as the one seen below.

6. You can now save the sync specification for future use by going to File -> Save.

7. The Dropbox you use is based on the saved username/password. You may need to change the Dropbox account you are currently associated with. To remove the saved username and password: Open "Windows Credential Manager", click on "Windows Credentials" and delete the entry for "CSPro_sync_Dropbox".

8. Open CSEntry on the tablet or mobile device to be used for data collection.

9. In the Application Listing menu tap the menu icon or menu button and choose Add Application from the menu. Choose the type of server to download the application from (Dropbox) and tap the Connect button.
You may be asked for your Dropbox credentials. Please enter the email and password for the Dropbox account created for the survey.

10. A list of all the application packages on the server will be displayed. Tap the **Install** button next to the package that you wish to install. For the Facility DV this will be the Facility_DV_SA application.

11. Once data has been entered, return to the case listing view and tap on the synchronization icon or select “Synchronize” from the menu. Synchronization can only be launched from the case listing view and “Synchronize” cannot be run while entering case data.

12. Once you tap “Synchronize”, CSPro will transfer data to/from Dropbox based on the selected specification. The first time you synchronize, you will get the Dropbox authorization dialogs. This is done only for the first synchronization. After that, the authorization is saved on the device. Logging in/out of Dropbox through the browser has no effect. CSPro only uses the credentials you entered for the initial connection to Dropbox. If you need to switch to a different Dropbox account, go to Settings -> Application Manager (named “Applications” on some devices) -> CSEntry -> Click on “Clear Cache” (“Clear Data” on some devices) which will remove the Dropbox information. CSPro will then ask for the Dropbox account when trying to synchronize and you can enter the correct account information.

### Synchronize by packaging application for manual transfer to tablets

1. On Dropbox, go to the CSPro folder and add a folder called DataSync. Inside the DataSync folder, add a folder called FACILITY_DV_DICT, and under the FACILITY_DV_DICT folder add folders called app, data, and dict. The file structure should look like the following.

   ![File Structure](image)

2. In the app folder copy the following files from CSPro SARA + DV/CSPro FACILITY DV_SA:

   ![Copy Files](image)

   Make sure that the lookup_files folder contains the relevant lookup files.

   **Note:** The synchronization system is case sensitive. Please specify the file structure exactly as described in this document.

3. The first time a tablet is synced for the survey, the files must be copied directly from the computer to the tablet. After that, updated can be synced through the internet. To copy the files to the tablet, attach the tablet to your computer using the USB cable.

4. Double click on the folder called csentry. Right click, select add new folder, and name the new folder FACILITY DV.
5. Double click on the csendry/FACILITY DV folder. Drag the files located in the CSPro/DataSync/app folder to the csendry/FACILITY DV folder on the tablet.

6. After the .PFF and .PEN files have been copied to the tablet, you can execute the application on the device. Open CSEntry on your device, click on the FACILITY_DV_SA application, and select Start New Case to begin entering data.

7. Once data has been entered, return to the case listing view and tap on the synchronization icon or select “Synchronize” from the menu. Synchronization can only be launched from the case listing view and “Synchronize” cannot be run while entering case data.

8. Once you tap “Synchronize”, CSPro will transfer data to/from Dropbox based on the selected specification. The first time you synchronize, you will get the Dropbox authorization dialogs. This is done only for the first synchronization. After that, the authorization is saved on the device. Logging in/out of Dropbox through the browser has no effect. CSPro only uses the credentials you entered for the initial connection to Dropbox. If you need to switch to a different Dropbox account, go to Settings -> Application Manager -> CSEntry -> Click on Clear Cache (this removes the Dropbox information). CSPro will then ask for the Dropbox account when trying to synchronize and you can enter the correct account information.

9. CSPro will indicate that it is syncing files. When the synchronization is complete, CSPro will issue the “Successfully synced” message.

10. The data will now be saved to the Dropbox account under CSPro/DataSync/FACILITY_DV_DICT/data. In addition, the dictionary will be saved in the CSPro/DataSync/FACILITY_DV_DICT/dict folder.

**Entering data on an Android tablet**

1. Upon opening CSEntry, all data entry applications on the device are displayed. Click on an application to open it. If only one application is on the device, it will open automatically.

2. Case listing screen: The case listing screen displays all cases that have already been added to the data file. Clicking on a case will open it for modification. Clicking on “start new case” or the icon of a cross in a circle
will add a new case. To delete a case, hard-press on the case until a deletion menu appears. The menu of this screen has options to sort the cases alphabetically or to display only incomplete cases.

3. The screen elements in CSEntry are the following:

1- Menu button- clicking on the menu button brings up options including show case tree
2- Name of the survey
3- Clicking on the pencil and paper icon brings up a screen to type a field-specific note
4- Clicking on the search icon and typing in a query allows you to filter the response listing
5- The field label is a short description of the field that you are currently entering; for SARA it is the question number
6- This is the question text for the field that you are currently entering
7- These are the response labels
8- These are the left and right hand navigation buttons, which correspond to moving forwards or backwards in the data entry application

4. There are several user input types:

- **Text box**: To enter data in a text box field, simply type the response using the keyboard. If a keyboard does not automatically appear, click on the field and a keyboard will appear.

- **Radio button**: When presented with a list of radio buttons, you must select one, and only one, response. Click on the response label or the corresponding radio button to make your decision.

- **Search box**: After clicking on the search icon, a space will appear where you can type a search query. The list of responses will automatically filter based on your search query. The full text of each response is searched, not necessarily starting from the first letter of the response.

- **Note box**: After clicking on the paper and pencil icon, you can type in a field-specific note. If you do not want to add a new note, you can press the Android back button to cancel.

- **Case tree**: Clicking on the CS icon brings up the case tree. The case tree displays all fields that have been entered in the data entry application, showing the field label and the response. If you click on a field, you will be taken to that field. This allows you to quickly move from one part of the questionnaire to another. You can dismiss the case tree by using the Android back button.
1.9 Concatenate data

After the data has been captured electronically, the data files have to either be:

1. Synced electronically (please see previous section on data syncing and skip to the next section in concatenating data)

   or

2. Moved to a single desktop or laptop computer for further processing.

Copying data files from the data collectors' computers to a back-up computer/laptop is usually done by the field supervisors.

At the end of the data collection, supervisors should have a folder for each team with the backup files:

FAILITY_DV_SA_TEAM1_DATE1
FAILITY_DV_SA_TEAM1_DATE2
FAILITY_DV_SA_TEAM1_DATE3

The latest file for each team should correspond to the final file. After validation by the supervisor, a copy of the final file should be created and renamed:

FAILITY_DV_SA_TEAM1_FINAL

The final data set should gather the final files from each team:

FAILITY_DV_SA_TEAM1_FINAL
FAILITY_DV_SA_TEAM2_FINAL
FAILITY_DV_SA_TEAM3_FINAL

FAILITY_DV_SA_DATA_COLLECTION_FINAL (REGION X)

This final data set should be transfer to the data manager/focal point at central level in charge of the compilation of the data from field collection. A back-up of all data files (final and stamped with dates) should precisely be saved as back-up and remain accessible during the cleaning and data processing phase.

When all data have been transferred, there should be only one final data folder enclosing all data files from all the field teams:

FAILITY_DV_SA_TEAM1_FINAL
FAILITY_DV_SA_TEAM2_FINAL

(…)

FAILITY_DV_SA_TEAM25_FINAL

Concatenate data files from Android tablet

When CSPro stores data in Dropbox it stores the data in a format specific to CSPro. CSPro uses this format to allow synchronization at the case level. In order to access, the data, the Data Viewer tool must be used to concatenate all the data files from the tablets and convert the file to a CSPro database file. To concatenate and convert data from android tablets:

1. Go to the start menu and select Programs -> CSPro 7.1 -> Data viewer

2. From the file menu of the Data Viewer select “Download”
3. In the resulting dialog box, select Dropbox and click on the connect button. You will need to enter the Dropbox account that is associated with the survey. CSPro will populate the “Data” dropdown using the data file list from Dropbox. Select the dictionary label associated with the files you wish to download. For the Facility DV, this will be Facility DV and SA.

4. In “Save As”, navigate to the folder in which to store the file and give the file a name. Click the “Save” button. For the Facility DV, save the file in the CSPro/DataSync/FACILITY_DV_DICT/data folder and call it 1_FACILITY_DV_SA_RAWDATA.csdb

5. Click “Download”. CSPro will download the file to the specified folder/file name and will display the contents of the file.

6. Once you have downloaded the file, to get updated data you can open the csdb file again in DataViewer and choose “Synchronize” instead of “Download”. This should be faster since it will only download cases that were updated since the file was last synced.

**Note:** You do **NOT** need to have Dropbox installed on the computer to use Dropbox synchronization or DataViewer. CSPro uses the Dropbox web API which is independent of the Dropbox client software that you install on your computer.

If you are having problems using the Data Viewer there are a few common reasons that you can check. 1. Make sure the internet network you are using has not blocked access to Dropbox. 2. Make sure that your computer has >NET framework version 4.7 or later installed.

If you want to change the Dropbox account associated with the DataViewer synchronization, you must remove the saved username and password. To do so, use the following steps:

**On Windows Desktop:** Open "Windows Credential Manager", click on "Windows Credentials" and delete the entry for "CSPro_sync_Dropbox".

**On Android:** Open "Settings", choose "Applications" (named "Application Manager" on some devices). Choose "CSEntry" and tap "Clear Data".

**On Windows Universal:** Open "Windows Credential Manager", click on "Web Credentials" and delete the entry for "CSPro_sync_Dropbox".

---

**Concatenate data files from Windows computer**

If data is collected on windows computers, CSPro provides a concatenate tool to concatenate all the data files into one file. To concatenate the data files:

1. Go to the start menu and select Programs -> CSPro 7.1 -> Concatenate data. A window like the one below will open.
2. For the output file, choose “Browse”. Again: Navigate to CSPro Facility DV_SA/Data, and provide the file name 1_FACILITY_DV_SA_RAWDATA.csdb.

3. For the method, select “Concatenate cases from each file using a dictionary and check for duplicates” and browse to CSPro Facility DV_SA and select the FACILITY_DV_SA.dcf file.

4. Click on the “Add” button, and navigate to the folder with all the data files. Choose them all.

5. Click on run to do the actual concatenation. A successful concatenation will provide the following message:

   ![Concatenate completed!]

6. A report will also open in a text viewer describing the process that has just been completed. You can close this window and close the CSPro Concatenation tool.

7. Browse to CSPro Facility DV_SA/Data and make sure the file 11_FACILITY_DV_SA_RAWDATA.csdb is in the folder.
1.10 Review data for completion in the field

Field supervisors can be trained to use tools developed in CSPro to check for completeness of the data collection while in the field. This will allow supervisors to identify any missing data and collect the appropriate information while still in the field. If a synchronization system has been set up which allows data to be transmitted to the central level in real-time, this process may be undertaken by the central instead of by field supervisors and the results communicated to the data collection team on an ongoing basis.

Two batch edit application has been created to track data inconsistencies, allowing more in-depth data cleaning and validation. The application identifies questions not answered that should have been answered as well as questions that shouldn’t have been answered but were based, on the specific skip patterns.

The first batch edit application (Facility DV data cleaning.bch) only checks for completeness of standard Facility DV/SA survey questions. If additional country specific questions have been added to the questionnaire, and you would like to be able to check for the completeness of these as well, additions will have to be made to the program. Similarly, if questions have been removed from the standard Facility DV/SA questionnaire, they will need to be removed from the batch application.

The second batch application (consCheck.bch) is to be used when the Facility DV/SA survey is being implemented in conjunction with the SARA survey. This application checks between the two surveys for consistency in responses regarding types of services offered.

To edit the Facility DV data cleaning batch edit application program:

1. Browse to CSPro SARA + DV/CSPro Facility DV_SA/Batch/Batch_1 and click on the Facility DV data cleaning.bch file.

2. Compile the logic by clicking on the toolbar, or select File/Compile from the main menu (or press Ctrl+K).

3. If no questions have been removed from the SARA core questionnaire, the logic should compile you will see Compile Successful in the Compiler Output under the logic.

4. If you see a dialog box that says Compile Failed, there is most likely logic in the application that corresponds to questions that have been removed. A red circle will appear in the margin indicating the approximate location of the error. The Compiler Output tab at the bottom of the screen will show you an error message to help you determine the error. Please check these errors in order to edit the logic to match the questionnaire.

5. If you would like to add logic to check the completeness of country specific questions added to the Facility DV/SA questionnaire, please refer to the existing code or request additional technical support to add in this programming.

To run the Facility DV data cleaning batch application, use the following steps:

1. Browse to CSPro SARA + DV/CSPro Facility DV_SA/Batch/Batch_1 and click on the Facility DV data cleaning.bch file.
2. Click on Run from the menu bar. Browse to CSPro SARA + DV/CSPro Facility DV_SA/Data and select Facility_DV_data.csdb file for the input file. Then click on ok. No output file is required.

3. When the application finishes running, a text file will open with the result of the batch such as the one below:

```
<table>
<thead>
<tr>
<th>Process Messages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Facility ID: 11041101</td>
</tr>
<tr>
<td>Facility name: Beyma CHF</td>
</tr>
</tbody>
</table>

*** Case [[11041101, 111112015001] has 2 messages: (0 E / 0 W / 0 I) |
| 0 -150 Immunization testing |
| 0 -296 DV ARV coverage DV_003 incomplete. |
| Facility ID: 11052201 |
| Facility name: KEMCO Clinic Pendashe |

*** Case [[111112015001] has 1 messages: (0 E / 0 W / 10) |
```

4. Each case will be identified by facility number and name and a list of error messages will be below. These messages correspond to inconsistencies in the data. Each issue should be reviewed with the survey team and the records edited appropriately to finalize the data set.

**Note:** The batch application uses the same lookup file as the data entry application to identify which DV modules are to be included in the batch for completeness.

To run the Facility DV/SA – SARA consistency batch application, use the following steps:

1. Browse to CSPro SARA + DV/CSPro Facility DV_SA/Batch/Batch_1 and click on the consCheck.bch file.

2. Click on Run from the menu bar. Browse to CSPro SARA + DV/CSPro Facility DV_SA/Data and select Facility_DV_data.csdb file for the input file. For the external file, browse to CSPro SARA + DV/CSPro SARA_2.3/Data and select the SARA_data.csdb. To cross-check facilities, the facility must be present in both data sets selected. Then click on ok. No output file is required.

3. When the application finishes running, a text file will open with the result of the batch such as the one below:
4. Each case will be identified by facility ID and will contain one or more of these messages:

- There is a Facility DV record, but no SARA record for facility XX
- There is a Facility DV record and a SARA record for this facility. The Facility DV record is incomplete—XX section is missing
- There is a Facility DV record and a SARA record for this facility. The SARA record is incomplete—XX section is missing
- XX is reported as offered in the Facility DV questionnaire, but reported as not offered in the SARA questionnaire
- XX is reported as offered in the SARA questionnaire, but reported as not offered in the Facility DV questionnaire

5. These messages correspond to inconsistencies in the data between the SARA and Facility DV/SA datasets. Each issue should be reviewed with the survey team and the records edited appropriately to finalize the data set.
1.11 Review and edit data in CSPro

The following steps should be taken to review the data in CSPro:

- **Step 1:** Open the concatenated data set using the data entry application
- **Step 2:** Review cases for key fields
- **Step 3:** Check for any duplicate facility codes
- **Step 4:** Delete any empty or duplicate cases
- **Step 5:** Separate final data set from supervisor validation data set
- **Step 6:** Compare supervisor validations to original data collection
- **Step 7:** Run the batch application to check for completeness of all records
- **Step 8:** Dependent verification if data collection was done on paper

The following sections will provide instructions on how to accomplish the above tasks in CSPro.

### Open the concatenated data set using the data entry application

1. Browse to the CSPro SARA + DV/CSPro Facility DV_SA folder and double click on the FACILITY_DV_SA.pff file.
2. In the menu bar, go to File -> Open data file. Under input data file select CSPro SARA + DV/CSPro Facility DV_SA/1_FACILITY_DV_SA_RAWDATA.csdb and click ok. The data file should open and all of the recorded cases should be listed in the tree on the left.
3. In the menu bar, go to View -> Cases in sort order to order the cases numerically which will make it easier to search and review cases.

### Review cases for key fields

Once the dataset is complete, each case will be reviewed for a number of key items including:
- Facility name and ID number correspond to each other
- Facility ID information is correct (facility type, managing authority)
- Interviewer ID information is present and correct
- GPS coordinates are valid (if applicable)
- Identify “other” responses for recoding as applicable

Use the sampling frame table to compare what is in the dataset with what was actually collected in the field. The result of this review will be a list of items that need to be corrected in the dataset. **ALL CHANGES TO THE**
**DATASET MUST BE MADE IN CSPRO.** If changes are made to the dataset in a different program, none of the automated analysis tools will be able to be used.

1. To review and edit information for a facility, double click on the record of interest in the right side tree. The record should open in the left window and you can use the tree on the right to scroll to the question of interest.

2. To edit a facility code, click in the facility number response box in the right window (Q001) and type in the new facility code then click enter. This same process can be used to edit other items in the record.

3. Now click on the stop icon in the tool bar to stop editing. The following box will pop up, select finish to save your edits.

---

### Check for any duplicate facility codes

The Index Files tool used above checks for duplicate case IDs, but doesn’t check for duplicate facility codes. The easiest way to check for duplicate facility IDs is to export the data set to Excel and check for duplicates in Excel. To do this:

1. On your desktop or laptop computer, press the Start button and navigate to the CSPro Export Data application. This will most likely be located in Programs -> CSPro7.0 -> Export data.

2. The first screen in the CSPro Data Export application will ask you for the Data Dictionary File. Navigate to the CSPro SARA + DV/CSPro Facility DV_SA folder, select the FACILITY_DV_SA.dcf file, and click Open.

3. The panel on the left should now display the data dictionary’s records and items in a selectable dictionary tree. From this dictionary tree, you can select the data you would like to export. We will be exporting the ID items and the Cover page sections to check on the facility number duplicates. Make sure the boxes next to these sections are checked.

4. This screen will also display various export options, such as the export format, how many files you would like the application to create, and whether you want to include XML Metadata. We will keep the default options for everything except the Export Format. Please select Tab delimited (txt) from the export format options.

5. To export the data select Run from the File menu.

6. The next screen will ask you to select the data file you would like to export. Please browse to FACILITY_DV_SA/Data, select 1_FACILITY_DV_SA_RAWDATA.csdb and click Open. This file contains the complete Facility DV/SA raw data set generated previously.

7. CSPro will then ask you to specify the name of the exported file. This is the TXT file that CSPro will create. Enter Facility_DV_SA_data_EXPORT.txt, and ensure that the file is saved in CSPro SARA + DV/CSPro Facility DV_SA/Data folder. Press Save.

8. You have now successfully exported data from CSPro. To open the text file in Microsoft Excel, start Excel and using the menu bar go to File -> Open and browse to the Facility_DV_SA_data_EXPORT.txt file, select it, and click ok. Make sure All Files is selected so that you can see the txt file.
9. The Text Import Wizard will open. The screens should look like the following as you work through the wizard:

10. Highlight the header row, click on the Data tab in the menu bar, and select Filter.

12. A box will open giving you the option for the colour scheme that will be used to identify duplicates. Select a colour of your choice and select ok.

13. Click on the arrow next to the column header Q001 so that the options menu opens, select sort by colour. If there are duplicate items they will have the colour you specified and will appear at the top of this list.

14. Identify any duplicate facility codes and then return to the CSPro data entry application to rectify the codes as required in the file 1_FACILITY_DV_SA_RAWDATA.csdb.

Delete a case

Occasionally a case will be stored by accident that contains no data or a duplicate case will be identified. These cases should be removed from the data set.
Duplicate cases are cases with the same facility code. If two cases appear to be duplicates according to facility name, but do not contain the same data, a list of criteria must be used to determine if it is a true duplicate. The following data elements could be used as the criteria for determining duplicates:

- district
- facility code/name
- GPS coordinates *(if collected)*
- facility type
- managing authority
- interviewer’s code.

If these are all the same it is safe to consider the cases as duplicates. At this point, the most complete case should stay in the data set. If both cases are complete, the case with latest time stamp should be kept.

To delete the case, open the CSPro data entry application and the data file 1_FACILITY_DV_SA_RAWDATA.csdb. In the left pane, right click on the record that is to be deleted, and choose “delete”:

Split final data set from supervisor validation data set

The supervisor validation records should be separated from the 1_FACILITY_DV_SA_RAWDATA.csdb dataset so they can be compared in the data cleaning phase. Please use the following steps to separate the supervisor validation records into their own dataset:

1. Browse to CSPro SARA + DV/CSPro Facility DV_SA/Batch/Batch_2 and click on the file Supervisor_split.pff. This will run a batch application to create two datasets: 2_FACILITY_DV_SA_FINALDATA.csdb which includes all the original data collector records and 3_FACILITY_DV_SA_SUPERVISORDATA.csdb which contains only the supervisor validations.

2. When it is finished running, a report of the process will open. You can close this window when it is complete. Browse to CSPro SARA + DV/CSPro Facility DV_SA/Data and check to see that the two files are present.

Compare supervisor validation to original data collection

The Compare Data tool is a CSPro tool that allows you to compare two data files and identify the differences. The data files must have the same structure, that is, be described by the same CSPro data dictionary. In addition, for comparisons to be made, the original case and the supervisor validation must have the same ID information and be located in different data sets.

In order to compare the supervisor validation record with the original facility record the two must have the same exact ID information. In order to accomplish this, please take the following steps.
1. Press the Start button and navigate to the Programs -> CSPro7.0 -> Export data.

2. The first screen in the CSPro Data Export application will ask you for the Data Dictionary File. Navigate to the CSPro SARA + DV/CSPro Facility DV_SA folder, select the FACILITY_DV_SA.dcf file, and click Open.

3. The panel on the left should now display the data dictionary’s records and items in a selectable dictionary tree. From this dictionary tree, you can select the data you would like to export. Click on the top box next to the dictionary icon to select all the data.

4. Next, open the tree called ID items. De-select everything EXCEPT facility number. The tree should look like the image below.

5. This screen will also display various export options, such as the export format, how many files you would like the application to create, and whether you want to include XML Metadata. We will keep the default options for everything except the Export Format. Please select CSPro (.dat, .dcf) from the export format options.

6. To export the data, press on the toolbar, or select Run from the File menu.

7. The next screen will ask you to select the data file you would like to export. Please browse to CSPro SARA + DV/CSPro Facility DV_SA/Data, select the file 2_FACILITY_DV_SA_FINALDATA.csdb, and click Open.

8. CSPro will then ask you to specify the name of the output data file and dictionary file. Browse to the CSPro SARA + DV/CSPro Facility DV_SA/Data/Supervisor validation folder and name the output data file 4_FACILITY_DV_SA_FINALDATA_EXTRACT.csdb and save the dictionary in CSPro SARA + DV/CSPro Facility DV_SA/Data/Supervisor validation as Facility_DV_SA_data_compare.dcf. Then click ok to run.
9. Repeat steps with the 3_FACILITY_DV_SA_SUPERVISORDATA.csdb dataset. Saving the file in CSPro SARA + DV/CSPro Facility DV_SA/Data/Supervisor validation folder as 5_FACILITY_DV_SA_SUPERVISORDATA_EXTRACT.

The data files are now ready to use the compare tool.

10. Navigate to Programs -> CSPro7.0 -> Compare data.

11. The first screen in the CSPro Compare data application will ask you for the Data Dictionary File. Navigate to CSPro SARA + DV/CSPro Facility DV_SA/Data/Supervisor validation, select the Facility_DV_SA_data_compare.dcf file, and click Open.

12. The panel on the left should now display the data dictionary's records and items in a selectable dictionary tree. Click on the top box next to the dictionary icon to select all the data. The screen should look like the image below.

13. To run the Compare function, click "Run" on the toolbar; press Ctrl+R; or from the File menu, select Run. For the input file, select the 4_FACILITY_DV_SA_FINALDATA_EXTRACT.csdb file from the CSPro SARA + DV/CSPro Facility DV_SA/Data/Supervisor validation folder. For the reference file, select the 5_FACILITY_DV_SA_SUPERVISORDATA_EXTRACT from CSPro SARA + DV/CSPro Facility DV_SA/Data/Supervisor validation folder. For the comparison method, make sure the "Compare Input to Reference and Reference to Input" box is selected. For the comparison method, make sure the "Compare in Indexed Order" box is selected. The screen should look like the image below.
14. Click OK to run the Compare tool. An output summarizing the results of the file comparison will be shown.

15. Examine the output. The output should look like the image below.

The input file and reference file are listed at the top. Each case in either file appears listed on the left, identified by the facility code. For each case, any difference between the input file and the reference file will be listed, with values for the input file under the column "Input File" and for the reference file under the column "Reference File" (far right). If the case exists in one file but not in the other, CSDiff will output "Case missing" in the relevant column.

In the screenshot below, the input and the reference file contain data for the facility with facility code 01020001. The results will show only differences between the two cases with the same ID. If the differences are only in spelling of facility name, facility location, other text only fields, no edits need to be made. If differences arise in other questions, make a list by facility of questions that have a mismatch. Send this list to the survey focal point for resolution of discrepancies. When the discrepancies have been resolved, return to the original data set and edit the record to reflect the changes.

16. Once you have selected the variables for which you want to compare, you can store these selections for future use. The file in which these selections are stored is a "Compare Specifications File". You can then use the "Compare Specifications File" at some later date to compare the set of variables specified in this file.
Batch application for completeness

A batch edit application has been created to track data inconsistencies, allowing more in-depth data cleaning and validation. The application identifies questions not answered that should have been answered as well as questions that shouldn’t have been answered but were based on the specific skip patterns. It is possible that the field supervisors or the central survey team have used this batch application to check for completeness in the field. If this is the case, it should still be used again to check for final completeness of the concatenated data set.

The batch edit application only checks for completeness of standard Facility DV/SA questions. If additional country specific questions have been added to the questionnaire, and you would like to be able to check for the completeness of these as well, additions will have to be made to the program. Similarly, if questions have been removed from the standard Facility DV/SA questionnaire, they will need to be removed from the batch application.

To edit the Facility DV data cleaning batch edit application program:

1. Browse to CSPro SARA + DV/CSPro Facility DV_SA/Batch/Batch_1 and click on the Facility DV data cleaning.bch file.

2. Compile the logic by clicking on the toolbar, or select File/Compile from the main menu (or press Ctrl+K).

3. If no questions have been removed from the SARA core questionnaire, the logic should compile you will see Compile Successful in the Compiler Output under the logic.

4. If you see a dialog box that says Compile Failed, there is most likely logic in the application that corresponds to questions that have been removed. A red circle will appear in the margin indicating the approximate location of the error. The Compiler Output tab at the bottom of the screen will show you an error message to help you determine the error. Please check these errors in order to edit the logic to match the questionnaire.

5. If you would like to add logic to check the completeness of country specific questions added to the Facility DV/SA questionnaire, please refer to the existing code or request additional technical support to add in this programming.

To run the Facility DV data cleaning batch application, use the following steps:

1. Browse to CSPro SARA + DV/CSPro Facility DV_SA/Batch/Batch_1 and click on the Facility DV data cleaning.bch file.

2. Click on Run from the menu bar. Browse to CSPro SARA + DV/CSPro Facility DV_SA/Data and select Facility_DV_data.csdb file for the input file. Then click on ok. No output file is required.

3. When the application finishes running, a text file will open with the result of the batch such as the one below:
Each case will be identified by facility number and name and a list of error messages will be below. These messages correspond to inconsistencies in the data. Each issue should be reviewed with the survey team and the records edited appropriately to finalize the data set.

To run the Facility DV/SA – SARA consistency batch application, use the following steps:

1. Browse to CSPro SARA + DV/CSPro Facility DV_SA/Batch/Batch_1 and click on the consCheck.bch file.

2. Click on Run from the menu bar. Browse to CSPro SARA + DV/CSPro Facility DV_SA/Data and select Facility_DV_data.csdb file for the input file. For the external file, browse to /SARA/CSPro SARA_2.3/Data and select the SARA_data.csdb. To cross-check facilities, the facility must be present in both data sets selected. Then click on ok. No output file is required.

3. When the application finishes running, a text file will open with the result of the batch such as the one below:

Each case will be identified by facility ID and will contain one of the following messages:

- There is a Facility DV record, but no SARA record for facility XX
• There is a Facility DV record and a SARA record for this facility. The Facility DV record is incomplete—XX section is missing

• There is a Facility DV record and a SARA record for this facility. The SARA record is incomplete—XX section is missing

• XX is reported as offered in the Facility DV questionnaire, but reported as not offered in the SARA questionnaire

• XX is reported as offered in the SARA questionnaire, but reported as not offered in the Facility DV questionnaire

5. These messages correspond to inconsistencies in the data between the SARA and Facility DV/SA datasets. Each issue should be reviewed with the survey team and the records edited appropriately to finalize the data set.

**Dependent verification (if applicable)**

Dependent verification is used to check that the electronic data are consistent with the responses in the paper version of the questionnaire. When you verify a case, you key the case a second time as if you were in Add mode. Even though there is already data in the data file, CSEntry does not show this to you. All fields on the current form start out blank. Each time you key a field, the system compares the value you keyed with the value in the data file. If the two values match, you move to the next field. If the values do not match, you get a message telling you so. When this happens, simply rekey the field. One of the following situations will occur:

• The second value you key matches the value in the data file. The system assumes your first value is in error and moves to the next field. There will be no change to the data file for this field.

• The second value you key matches the first value you keyed. The system assumes the value in the data file is in error and moves to the next field. The new value, which you keyed twice, will replace the original value in the data file.

• The second value you key matches neither the value in the data file nor the first value you keyed. The system will throw away the first value you keyed, show you the mismatch message and wait for you to rekey the field again.

To begin verifying cases

Press Ctrl+V; or from the Mode menu, select Verify; or click on the toolbar to begin verifying cases from the beginning of the data file or where you left off verifying. This will begin a new Verify mode session. CSEntry keeps track of the last case that was verified, and positions you automatically to the next case to verify. If you did not complete verifying the last case, there will be a partially verified case in the data file marked with in the file tree. When you begin verification, you will be asked whether you want to begin verification where you left off within the case. You cannot verify cases if there are partially added or partially modified cases in the file. You must finish these cases before you can resume verification. You may verify as many cases as you like until you reach the end of the data file.

Show Fields

Sometimes you need to see the values in the data file on the screen. This is particularly useful if you are unsure which case you are verifying or exactly where in the case you are. You can use the Ctrl+F2 key to do this. When you press the Ctrl+F2 key you will see the values for all the fields on the current form. You must press Ctrl+F2 again to resume verifying.
1.12 Batch edit application for indicator generation

A batch edit application contains logic that you can apply against one set of files to produce another set of files and reports. For the Facility DV, we will use a batch edit application to create additional variables, specifically the Facility DV indicators. In order to create additional variables, the only requirement is that space be allocated (via the data dictionary for the file) in the output record. For the Facility DV questionnaire, all the Facility DV indicators have been placed in the data dictionary and a batch edit application has been created to assign the values to each indicator based on the responses to the questions in the questionnaire. If changes have been made to the Facility DV core questionnaire, these changes will also need to be reflected in the batch edit application.

Open and explore the batch application

1. Navigate to CSPro Facility DV_SA/Batch/Batch_3 and open the file Facility DV SA_indicators.bch.

The workspace

The Facility DV batch edit application opens. The screen is divided into three main work areas: the Tree View, the Logic View and the Message View.

Tree view

There are three types of trees, corresponding to the three tabs at the bottom part of the left screen: the Files tree (Files), the Dictionary tree (Dicts) and the Edits tree (Edits).

The files tree and the dictionary tree are the same as seen in the data entry application. The edit tree is new to the batch edit application and will be identical to the dictionary tree; that is, edit items will be listed as named and ordered in the dictionary. If code has been written for a given edit level, record, or item, a check mark will appear superimposed on the icon for that entity. This is how, at a quick glance, you can see where you have placed programming logic.

Logic view

The logic view is the window block in the upper portion of the right half of the screen. It is the programmer’s “clean slate”, to which may be added logic for any part of the data file: any item, any section, any record, even the file as a whole. It is up to the programmer to determine the correct placement and sequence of execution for each logical element.

Message view

The message view is the window block in the lower portion of the right half of the screen. It is devoted to messages (user-created and system-generated). As with the Tree View, tabs are available to the programmer; clicking on one of them will make the contents of that view active. The Compiler Output tab displays errors found during compilation of your program; if the code compiled successfully, it will state "Compile Successful." The Message tab is used to type in error messages that will be used in the execution of the program.

Assign strata for analysis

If using the Facility DV automated analysis tool, you will need to assign values for the strata to be used in the analysis tool. There are four possible strata to be assigned: region/district, facility type, managing authority, and urban/rural.

1. Click on the + next to RECODES_GSR_EDT on the left side tree to expand the section.
2. The first four items in the tree are for assigning stratum and look like the following:

3. Click on STRATUM_2 in the tree. On the right, you should now see a procedure window. Under PROC STRATUM_2, you will need to write logic to map the facility types in the questionnaire to the categories to be used in the analysis. For example, the core questionnaire contains the following categories for facility type:

<table>
<thead>
<tr>
<th>Type of facility*</th>
<th>National Referral Hospital</th>
<th>District/Provincial Hospital</th>
<th>Health Centre/Clinic</th>
<th>Health Post</th>
<th>Maternal/Child Health Clinic</th>
<th>Other (Specify)</th>
</tr>
</thead>
<tbody>
<tr>
<td>* These should be adapted at country level prior to implementation*</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>95</td>
</tr>
</tbody>
</table>

For the analysis, the results will be presented as hospitals and primary care. Logic must be written to assign each of the above facility types to either hospitals or primary care. An example of the logic required to do this is below:

if Q007 in 1,2 then
    STRATUM_2 = 1
elseif Q007 in 3,4,5,96 then
    STRATUM_2 = 2
endif;

4. When you have finished writing the logic, click on the compile button to ensure your statement is valid.

5. Repeat this process for the remaining applicable stratum.
Apply weights

If a sample (as opposed to a census) survey has been implemented, weights will need to be calculated and applied to the data set. The analysis of the facility data verification requires the use of survey weights so that the estimates generated are representative of health facilities. A total of six weights must be calculated for the standard facility DV exercise which includes five indicators (ANC1, DTP3, Currently on ART, Notified cases of TB, and Malaria cases).

The Facility DV-SA makes use of six different weights defined as follows:
- WEIGHT — survey analytical weight
- WEIGHT1 — ANC post-stratification weight
- WEIGHT2 — Immunization post-stratification weight
- WEIGHT3 — ART post-stratification weight
- WEIGHT4 — TB post-stratification weight
- WEIGHT5 — Malaria post-stratification weight

For more detailed information on how to calculate each of the weights, please refer to the DQR toolkit which contains an annex with detailed information on how each weight should be calculated. In this section, we will review how to assign weights in CSPro.

For this example, we will assume that the sample was stratified by facility type and managing authority giving the following weights:

<table>
<thead>
<tr>
<th>Stratum</th>
<th>WEIGHT</th>
<th>WEIGHT1</th>
<th>WEIGHT2</th>
<th>WEIGHT3</th>
<th>WEIGHT4</th>
<th>WEIGHT5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hospital - private</td>
<td>2.692</td>
<td>3.365</td>
<td>3.365</td>
<td>3.365</td>
<td>3.365</td>
<td>3.365</td>
</tr>
<tr>
<td>Primary - public</td>
<td>3.077</td>
<td>4.000</td>
<td>4.000</td>
<td>4.000</td>
<td>4.000</td>
<td>4.000</td>
</tr>
<tr>
<td>Primary - private</td>
<td>2.800</td>
<td>3.111</td>
<td>3.111</td>
<td>3.111</td>
<td>3.111</td>
<td>3.111</td>
</tr>
</tbody>
</table>

Logic must be written to assign the weight to the corresponding facilities. To do this, use the following steps:

6. Click on the + next to RECODES_GSR_EDT on the left side tree to expand the section.

7. Click on the item WEIGHT in the tree. On the right you should now see a procedure window. Under PROC WEIGHT, you will need to write logic to map the facility types and managing authorities to the weights. An example of the logic required to do this is below:

   if Q007 in 1,2 and Q008 = 1 then
     WEIGHT = 2.846
   elseif Q007 in 1,2 and Q008 in 2,3,4,96 then
     WEIGHT = 2.692
   elseif Q007 in 3,4,5,96 and Q008 = 1 then
     WEIGHT = 3.007
   elseif Q007 in 3,4,5,96 and Q008 in 2,3,4,96 then
     WEIGHT = 2.800
   endif;

8. When you have finished writing the logic, click on the compile button to ensure your statement is valid.
Logic will need to be written for all of the weight variables (WEIGHT, WEIGHT1, WEIGHT2, WEIGHT3, WEIGHT4, WEIGHT5). Please note, in order for the automated Excel based analysis tool to work, weights must be assigned for all facilities for all six weights.

**Edit country specific items**

The batch edit application is written for the core Facility DV questionnaire. If any edits have been made for a country implementation of the Facility DV, those edits must also be made in the batch edit application. For example, if a question is deleted from the Facility DV questionnaire, ALL associated logic in the batch must be deleted as well.

**Run the batch application**

Running the batch edit application will generate values for the Facility DV indicators. Take the following steps to run the batch edit application:

1. From the File menu, select Run or press Ctrl+R. If you’ve made changes since you last compiled, CSPro will first compile your application.

2. The following dialog box will appear:

   ![Image of dialog box]

   The input data file is the data file against which you wish to run your batch application. This data file will not be modified in any way; it will only be opened, read, and closed. Navigate to CSPro Facility DV_SA/Data and select the 2_FACILITY_DV_SA_FINALDATA.csdb file for the input data file. The output data file is where the results of the batch edit application will be written. Navigate to CSPro Facility DV_SA/Data folder and type the name 6_FACILITY DV_INDICATORS into the output file field.

3. Click on Ok and the batch edit will now run. When it is complete, a process summary window will pop open. You can close this window.

4. Go to File -> Save or Ctrl+S to save your work thus far and then File -> Exit to close the batch edit application.

5. Browse to the CSPRO Facility DV_SA/Data folder and there should now be a file called 6_FACILITY DV_INDICATORS.csdb. This is the data file you will use for exporting the Facility DV indicators.
1.13 Export indicators

CSPro has a built-in Export Data application that allows you to quickly and easily export data in a variety of formats. The exported data can then be imported into different software programs depending on your needs. In order to be able to use the standardized Facility DV analysis tool, the data will need to be exported in csv format. Please use the steps below to export the data to csv format:

Open the CSPro Export Data application

1. On your desktop or laptop computer, press the Start button and navigate to the CSPro Export Data application. This will most likely be located in Programs -> CSPro7.0 -> Export data.

2. The first screen in the CSPro Data Export application will ask you for the Data Dictionary File. Navigate to the CSPro Facility DV_SA folder, select the FACILITY_DV_SA.dcf file, and click Open.

Select items for export

1. The panel on the left should now display the data dictionary's records and items in a selectable dictionary tree. From this dictionary tree, you can select the data you would like to export. We will be exporting three sections: ID items, Cover page, and Section 9: Recodes data verification. Make sure the boxes next to these three sections are checked.

2. Within the ID items section, the item called underscore needs to be unselected. To do this, click on the + next to ID items to expand the section. Next to “an underscore”, uncheck the box.

3. This screen will also display various export options, such as the export format, how many files you would like the application to create, and whether you want to include XML Metadata. We will keep the default options for everything except the Export Format. Please select Tab delimited (txt) from the export format options.

Export data for the Facility DV chartbook

1. Once you are ready to export the data, select Run from the File menu.

2. The next screen will ask you to select the data file you would like to export. Please browse to the CSPro Facility DV_SA/Data folder, select the 6_FACILITY DV_INDICATORS file, and click Open. This file contains the Facility DV indicators generated previously.

3. CSPro will then ask you to specify the name of the exported file. This is the TXT file that CSPro will create. Enter 7_FACILITY DV_INDICATORS_EXPORT.txt, and ensure that the file is saved in the CSPro Facility DV_SA/Data folder. Press Save.

4. You have now successfully exported data from CSPro. You can now open the TXT file, view the data in Microsoft Excel, and import it into the Facility DV chartbook.
Export data to other file formats for additional analysis

The CSPro export function supports export to the following file formats:

- Tab delimited (.txt)
- Comma delimited (.csv)
- Semicolon delimited (.csv)
- CSPro (.csdb, .dcf)
- SPSS (.csdb, .sps)
- SAS (.csdb, .sas)
- STATA (.csdb, .dct, .do)
- R (.csdb, .R)

If you would like to export the data to one of these formats, follow the following steps:

Open the CSPro Export Data application

1. Determine if the data entry application was used in English or French. If French was use, you will need to use batch_4 to delete the English value set labels so that the French that you have adapted for the survey will export with the dataset. If the survey was conducted in English, skip to number 3.

2. To remove the English value sets, go to CSPro SARA + DV/CSPro Facility DV_SA/Batch/Batch_4 and double click on deleteValueset.pff. Running this batch application does the following:
   - The FACILITY_DV_SA.dcf is rewritten, so that in all cases where there are more than one valueset, the first one (English) is deleted.
   - After deleting the valuesets, the batch runs through the dictionary file one more time, to ensure that all valuesets have names ending in FRA.
   - If the batch is run once, a backup is saved as FACILITY_DV_SA_backup.dcf. This is, however overwritten next time the batch is run, so if it is run twice, both of your dictionary files will only have French value sets. Please be careful NOT to do this!

3. On your desktop or laptop computer, press the Start button and navigate to the CSPro Export Data application. This will most likely be located in Programs -> CSPro6.3 -> Data tools -> Export data.

4. The first screen in the CSPro Data Export application will ask you for the Data Dictionary File. Navigate to the CSPro SARA + DV/CSPro Facility DV_SA folder, select the FACILITY_DV_SA.dcf file, and click Open.

Select items for export

1. The panel on the left should now display the data dictionary’s records and items in a selectable dictionary tree. From this dictionary tree, you can select the data you would like to export.

2. This screen will also display various export options, such as the export format, how many files you would like the application to create, and whether you want to include XML Metadata. We will keep the default options for everything except the Export Format. Please select the export format that you would like to use.
Export data

1. Once you are ready to export the data, select Run from the File menu.

2. The next screen will ask you to select the data file you would like to export. Please browse to the data file of interest, and click Open.

3. CSPro will then ask you to specify the name of the exported file. Specify a file name of your choice and click Save. You have now successfully exported data from CSPro.

4. If you exported the data to STATA, the export creates three files: .dat, .dct, and .do. In order to create the STATA dataset, you need to open STATA, click on File -> Do and navigate to the .do file created in the data export process. This will read in the .dat and .dct files to load the data and all value set labels. Once this is complete click on File -> Save to save the dataset as a .dta (STATA file format).
1.14 District DV/SA application

The District DV/SA application is a separate stand-alone CSPro application as it is collected at the district level as opposed to the facility level. The same general principals apply to the District DV/SA as to the SARA and Facility DV/SA tools. This chapter will provide additional information about the structure of the District DV/SA and how to configure the application.

Preparing to open the District DV/SA CSPro application

Setting time and date on the tablets/laptops

The District DV/SA application uses the computer time and date in the program, so it is very important that the date and time is set correctly on the tablets to use in the field.

Create a folder to store the District DV/SA files

Download the CSPro SARA + DV zip file and unpack the file CSPro SARA + DV.zip to the desktop. This creates the folder CSPro SARA + DV, in which the SARA application, Facility Data Verification application, and District Data Verification are located. We will be focusing on CSPro District DV_SA folder which contains the District DV/SA configuration and sample files and is where the data are stored and appropriately organized. When setting the District DV/SA survey up for the tablets to be used during the interviews, copy the shortcut “CSPro SARA + DV/CSPro District DV_SA/DISTRICT_DV_SA.pff - Shortcut” to the desktop. The interviewer can then double click on this file to start up the application.

The District DV/SA CSPro files structure

The Facility DV/SA file hierarchy

When unpacked, the file hierarchy of the Facility DV/SA is like this:

- C:/CSPro SARA + DV/CSPro District DV_SA
  - The main application to start up the District DV/SA survey is located here.
  - /Batch
    - CSPro batch programs that are used with District DV/SA
    - /Batch_1
      - The batch program for data processing (completeness)
    - /Batch_3
      - The batch program for indicator generation
    - /Batch 4
      - The batch program to delete value sets
  - /Data
    - The raw data files for the District DV/SA survey
  - /Lookup_files
    - Files that are used by the application. These will be edited for each implementation of the District DV/SA.

When moving around in the hierarchy, you will see that there are many files. This is because CSPro generates many different kinds of files. An interviewer need not to know anything about the files or hierarchy as a shortcut to launch the data entry application is provided for them. As an administrator of the application, however, you need to know more. There are several very important folders which you will need to be quite familiar with including the lookup folder and the data folder.

File types in CSPro
In the main District DV/SA folder, there are many files and a multitude of file types. The following is an overview of the different types of files of CSPro. It is highly recommended to configure Windows Explorer to show extensions for known file types. A folder with CSPro files becomes rather confusing without the extensions showing. To do this: Open Control panel, and in the upper right corner choose “View by small icons”. Then you can click on “Folder options”. Choose the tab “View”, and un-tick “Hide extensions for known file types” Then click OK.

<table>
<thead>
<tr>
<th>File name</th>
<th>File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DISTRICT_DV_SA.dcf</td>
<td>Data Dictionary File</td>
<td>Each file manipulated by CSPro must be described by a data dictionary. The data dictionary file contains information defining the layout of the data file, including levels, records, items, value sets, and values.</td>
</tr>
<tr>
<td>DISTRICT_DV_SA.ent</td>
<td>Data Entry Application File</td>
<td>The data entry application file is the master file for the data entry application. This file specifies all other files contained in the application, along with other information.</td>
</tr>
<tr>
<td>DISTRICT_DV_SA.fmf</td>
<td>Form File</td>
<td>The forms file contains information about forms, their fields, text, and rosters. The forms file also contains the name of the associated data dictionary file. The flow during data entry, that is, the order in which forms and fields are entered, is defined in the forms file, not in the data dictionary.</td>
</tr>
<tr>
<td>DISTRICT_DV_SA.ent.apc</td>
<td>Logic File</td>
<td>The logic file contains all the CSPro language statements which control the application. There is one logic file associated with each application.</td>
</tr>
<tr>
<td>DISTRICT_DV_SA.ent.mgf</td>
<td>Messages File</td>
<td>The message file is a text file where you can store message text and an associated message number. The message is displayed when an &quot;errmsg&quot; function with the message number is executed in a data entry application. A message may contain parameters.</td>
</tr>
<tr>
<td>DISTRICT_DV_SA.ent.qsf</td>
<td>Question File</td>
<td>The question file contains information related to CAPI data entry applications. Such information includes question text to appear on the screen with each field and when the operator presses the help key.</td>
</tr>
<tr>
<td>DISTRICT_DV_SA.pff</td>
<td>Program Information File</td>
<td>Program information files are used to run applications or tools in production mode.</td>
</tr>
<tr>
<td>DISTRICT_DV_SA.pen</td>
<td>Binary data entry application</td>
<td>A binary data entry application consists of one single file, which includes the same information as the set of text files that normally make up a data entry application. This file cannot be changed in any way nor opened by the CSPro designer.</td>
</tr>
</tbody>
</table>

**File types in the data folder**

<table>
<thead>
<tr>
<th>File name</th>
<th>File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>District_DV_SA.csdb</td>
<td>Data file</td>
<td>This is the file containing the actual data.</td>
</tr>
<tr>
<td>District_DV_SA.csdb.log</td>
<td>Log file</td>
<td>Operator statistics</td>
</tr>
<tr>
<td>District_DV_SA.csdb.lst</td>
<td>Listing File</td>
<td>Listing of data entry activity for each data file</td>
</tr>
</tbody>
</table>
Configure the District DV application

The District DV/SA application needs to be configured before it can be used in a survey – without this configuration it will not work. Most of the configuration is about either changing csv (semi-colon separate) files, or creating new ones, and they are all to be found in the CSPro District DV_SA/lookup_files folder. It may also require using the configuration file and editing the .pff file. Detailed instructions for each step in the configuration process are found in the following sections.

Create the sample file

The District DV/SA application sample file is a .csv file that specifies the region, district, and units that can be selected for the survey.

The following table shows the structure of the sample file:

<table>
<thead>
<tr>
<th>Region number</th>
<th>Region name</th>
<th>District number</th>
<th>District name</th>
<th>Unit number</th>
<th>Unit name</th>
</tr>
</thead>
</table>

The columns should have no row containing headers. The following is an example of a 2-level sample file. It is optional to leave repeating fields (like for instance repeating region number or names) blank. An example sample file can be found in the lookup_files folder of the District_DV_SA application.

The sample file has to be sorted by the columns REGION ID * DISTRICT ID * UNIT ID. This is done in excel by choosing custom sort, and then specify the sorting like this:
When the sample file is made, remember to save it as a *semi colon separated csv file*. It has to have the name *Sample.csv* and to be placed in the folder *CSPro SARA + DV/CSPro District DV_SA/Lookup_files*

1. In Excel: choose File – Save as
2. In the field “Save as type”. Click on the arrow on the right to get the dropdown menu and select “CSV (MS-DOS)(*.csv). Give the file the name “Sample.csv”
3. Excel then pops up this window:

   ![Excel window](image)

   press “OK”
4. And this window:

   ![Excel window](image)

   press “Yes”.

Please note: The file has to have the name *Sample.csv* and be placed in the folder *CSPro SARA + DV/CSPro District DV_SA/Lookup_files*.

---

**Create the interviewer ID file**

When running District DV/SA application, the application asks for the ID number of the interviewer. This is a two digit number assigned to uniquely identify each interviewer or interviewing team. Below is an example of how the interviewer number question is displayed in CSPro:

![CSPro screenshot](image)
The information about the interviewers and the assigned ID number has to be saved in the file `CSPro SARA + DV/CSPro District DV_SA/Lookup_files/listOfInterviewers.csv`, and it has to have the following format:

01;Team 1
02;Team 2
03;Team 3
04;Team 4
05;Team 5

Open the `listOfInterviewers.csv` file in either Excel or a text editor to edit the names and numbers for the interviewers. Please remember to maintain the above format.

### Configure the DV module selection

The District DV/SA questionnaire includes a number of modules that can be selected. The survey manager and steering committee will select which modules are to be included in the survey. The CSPro application must be configured to reflect this decision at country level.

To leave out a module, open the file `CSPro SARA + DV/CSPro District DV_SA/Lookup_files/ListOfDvModules.csv` in either Excel or a text editor and delete the rows containing the modules that are not to be included in the survey.

### Adding new DV modules

This paragraph assumes that the responsible knows enough CSPro to make the new records and forms needed for the DV module to be added.

First a record must be added to the dictionary that contains the additional questions to be added. There are no requirements for where the record must be placed.

After the record has been created and the fields added to it, all the country specific items have to be placed in the `DV_COUNTRY_SPECIFIC_FORM`. Also, this form has to be listed in the lookup file `ListOfDvModules.csv`.

### Change the display language

The District DV/SA survey has been designed to be used both in English and French speaking countries, and new languages can easily be added. The information about what language to use is taken from the file that starts up District DV/SA application: the `DISTRICT_DV_SA.pff` which is on the root of the CSPro District DV_SA folder.

The default language is English, and if French is to be used, the pff file has to be edited:

1. Open `DISTRICT_DV_SA.pff` in a text editor of your choice (for example by searching for notepad in the start menu and then open it from notepad (remember to choose the option “all files (*.*) next to the file name field))

2. Change the last line of the file so that it becomes

   Parameter=FRA;2000;NOQUIT

3. The ENG;1000/FRA;2000 portion of the command refers to the language. This is followed by a command `NOQUIT` which tells the application to return to the main menu after a facility record is complete. If you remove “NOQUIT” from this line, CSEntry will shut down once a case is complete and will need to be restarted from the pff to enter a new facility.

4. Save and exit.
District settings for entering facility level data into an electronic health information system

One of the key questions in the District DV/SA module is:

“Does the district enter facility level data into an electronic health information system (i.e. DHIS) and does the system automatically aggregate data to create a district report?”

If facility level data is entered into an electronic health information system, the recounting at district level will be skipped. If facility level data is NOT entered into an electronic health information system (i.e. facility level information is aggregated by hand and a paper district report is submitted to the next administrative level), the recounting at district level will be implemented.

The CSPro application is hard-coded to enforce this skip pattern across all indicators and all facilities. The default setting is to IMPLEMENT the recount. If the recount should be skipped, you will need to change the CSPro default setting. To do this:

1. Open the District_DV_SA.ent CSPro application file and navigate to the Forms view (click on the form icon on the toolbar)

2. Click on the logic button and then click on the level called “District DV and SA questionnaire” to see the logic for that level. Look at the logic under PROC DISTRICT_DV_QUEST. Find the line that says “recount = “Yes” which is highlighted in yellow below.

3. Change the word “Yes” to “No”. This will turn off the recounting portion of the district data verification assessment for all indicators.
Edit and run the District DV/SA application

To add and delete questions, run the application, concatenate data, generate indicators, and export data, please refer to above instructions for the Facility DV/SA application as the instructions are the same for both applications.

Select items for export

The process for exporting items for the District DV/SA application is the same as for the Facility DV/SA application with the exception of which items to select. This section provides information on which items to select for export to use the District DV/SA chartbook. Please refer to the above instructions for the Facility DV/SA application for more information on exporting data as the instructions are the same for both applications.

1. The panel on the left of the export window should display the data dictionary's records and items in a selectable dictionary tree. From this dictionary tree, you can select the data you would like to export. We will be exporting three sections: ID items, HMIS unit identification, and Recodes. Make sure the boxes next to these three sections are checked.